Some FlexEvent are not fully supported on new Firefox 45

RESOLVED WONTFIX

Status

()

--
major
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: ghe, Unassigned)

Tracking

({flashplayer})

45 Branch
flashplayer
Points:
---

Firefox Tracking Flags

(firefox45blocking wontfix, firefox46+ wontfix, firefox47+ wontfix, firefox48+ wontfix, firefox-esr3845+ wontfix, firefox-esr45- wontfix)

Details

(URL)

Attachments

(3 attachments)

661.65 KB, text/plain
Details
42.27 KB, text/plain
Details
254.73 KB, application/x-rar
Details
(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; InfoPath.3; rv:11.0) like Gecko

Steps to reproduce:

One www.pogo.com where there are many flash games, users are reporting that the latest version of Flash on Firefox browsers is causing issues with loading a few games.

Firefox Browser:
Claire Hart - Blank white screen.
Alhambra Solitaire - Loading bar gets to 99%
Gems 3 - Stuck at 99%
Dominoes Single Player - Stuck on 99%
Other games may have issues with it too.

Url links:
Free Games:
http://www.pogo.com/games/claire-hart-soul-searcher

Club only games:
http://www.pogo.com/games/gems3
http://www.pogo.com/games/alhambrasolitaire
http://www.pogo.com/games/tpdominoes


Actual results:

Looks like the games use Flex rather than the original as3 have the loading issue:

For example, the following code no longer works:
event.target.getLoader().content.addEventListener( FlexEvent.APPLICATION_COMPLETE, onGameLoaded );
 
For the game Claire Hart, the background image is tabbed in Main.mxml which is a Flex component, so it doesn’t work and show a blank page after the upgrade.

<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml"
				layout="absolute" 
				width="760" 
				height="570"
				horizontalAlign="center"
				frameRate="30" clipContent="false" 
				focusOut="onFocusOutHandler()" 
				deactivate="onFocusOutHandler()"
				keyDown="onKeyDownHandler(event)"
				creationComplete="onCreationComplete(event)"
				xmlns:local="*" xmlns:s="library://ns.adobe.com/flex/spark">

[Embed(source='assets/game/backgroundRepeat.png')]
private function onCreationComplete(event:FlexEvent):void
{
                …
}



Expected results:

The flex games can be loaded successfully.

The FlexEvent is supported by new FireFox
(Reporter)

Updated

3 years ago
Severity: normal → critical
Priority: -- → P1
Component: Untriaged → Plug-ins
Keywords: flashplayer
Product: Firefox → Core

Updated

3 years ago
Severity: critical → normal
Priority: P1 → --
Summary: Some FlexEvent are not fully supported on new Firefox(45) → Some FlexEvent are not fully supported on new Firefox 45

Comment 1

3 years ago
These games worked in the past with FF44 and older versions, and now they don't work anymore after the update to Flash 21. I doubt it's an issue about Firefox 45 not supporting FlexEvent because this event was already used in the past and it worked.

Maybe Flash 21 has a regression.

Comment 2

3 years ago
Did you modify these games recently to add the FlexEvent?
Flags: needinfo?(ghe)
(Reporter)

Comment 3

3 years ago
(In reply to Loic from comment #2)
> Did you modify these games recently to add the FlexEvent?

No, those game are not modified for a long time
Flags: needinfo?(ghe)

Comment 4

3 years ago
So the issue is probably due to the update to Flash 21.
(Reporter)

Comment 5

3 years ago
(In reply to Loic from comment #4)
> So the issue is probably due to the update to Flash 21.

It works fine on IE and Chrome. I installed Flash 15 and Flash 20 on Firefox, they both have the same issue

Comment 6

3 years ago
(In reply to Rivery from comment #5)
> (In reply to Loic from comment #4)
> > So the issue is probably due to the update to Flash 21.
> 
> It works fine on IE and Chrome. I installed Flash 15 and Flash 20 on
> Firefox, they both have the same issue

So why it worked in the past with Flash 20 and FF44 and now, it doesn't work anymore with Flash 21 and FF44?
(Reporter)

Comment 7

3 years ago
(In reply to Loic from comment #6)
> (In reply to Rivery from comment #5)
> > (In reply to Loic from comment #4)
> > > So the issue is probably due to the update to Flash 21.
> > 
> > It works fine on IE and Chrome. I installed Flash 15 and Flash 20 on
> > Firefox, they both have the same issue
> 
> So why it worked in the past with Flash 20 and FF44 and now, it doesn't work
> anymore with Flash 21 and FF44?

The issue is newly found after Firefox upgradge to 45 on my machine
(Reporter)

Comment 8

3 years ago
(In reply to Loic from comment #6)
> (In reply to Rivery from comment #5)
> > (In reply to Loic from comment #4)
> > > So the issue is probably due to the update to Flash 21.
> > 
> > It works fine on IE and Chrome. I installed Flash 15 and Flash 20 on
> > Firefox, they both have the same issue
> 
> So why it worked in the past with Flash 20 and FF44 and now, it doesn't work
> anymore with Flash 21 and FF44?

The issue is newly found after Firefox upgradge to 45 on my machine. So I install/uninstall different flash player version on new browser and they all have the issue to load the game.
(Reporter)

Comment 9

3 years ago
could it be some new change on sandbox?
(Reporter)

Comment 10

3 years ago
There's an easy way to reproduce the issue, to load:

http://cdn.hauntedhog.alpha.pogospike.com/Main.swf 

On IE and Chrome you can see the background image but on Firefox you cannot. It's because the drawback method in creationComplete of the flex application is no longer called.

Comment 11

3 years ago
[Tracking Requested - why for this release]: pogo games need to work. I think understanding this should block further 45 release rollout.

Rares, finding a regression range is urgent for this.
tracking-firefox45: --- → ?
tracking-firefox46: --- → ?
tracking-firefox47: --- → ?
tracking-firefox48: --- → ?
Flags: needinfo?(rares.bologa)
Keywords: regression, regressionwindow-wanted
Tracking as it seems to be critical
status-firefox45: --- → affected
tracking-firefox45: ? → blocking

Comment 13

3 years ago
There is something I don't understand.
FlexEvent (*) was used in these Flash games before FF45 or Flash 21 and it worked fine. Now, with Flash 21, it doesn't work anymore in FF45 or in versions < FF45. Why should it be a regression in Firefox?

(*) http://help.adobe.com/en_US/FlashPlatform/reference/actionscript/3/mx/events/FlexEvent.html
(In reply to Rivery from comment #0)
> Firefox Browser:
> Claire Hart - Blank white screen.
> Alhambra Solitaire - Loading bar gets to 99%
> Gems 3 - Stuck at 99%
> Dominoes Single Player - Stuck on 99%
> Other games may have issues with it too.

When I read all that it reminds me on bug 1254856 which will actually be fixed for Firefox 45.0.1. Could it be that we have the same underlying issue with 3rd party cookies here?

It might be worth checking the 45.0.1 release candidate build:
http://archive.mozilla.org/pub/firefox/candidates/45.0.1-candidates/build1/
We've managed to reproduce this bug on several platforms and Fx versions, using different Flash plug-in versions, e.g. 20.0.0.306, 21.0.0.182, 19.0.0.245.

Here's a summary of what we've investigated so far:
- affected versions: 38.7.1esr-build1, 45.0.1esr-build1, 45.0.1-build1, 44.0.2-build3, 47.0a2 (2016-03-16), 48.0a1 (2016-03-16), 46.0b1-build8
- affected platforms: Windows 7 x64, Windows 10 x86, Mac OS X 10.9.5
- behavior: a blank container is displayed instead of the actual flash content
Severity: normal → major
Status: UNCONFIRMED → NEW
status-firefox46: --- → affected
status-firefox47: --- → affected
status-firefox48: --- → affected
status-firefox-esr38: --- → affected
status-firefox-esr45: --- → affected
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
Rivery, the bug is reproducing for me also on Firefox 44 and even on FF 41, with different Flash versions (18, 20, 21).

 Could you please try to find a regression range using Mozregression tool?
You can install the tool from: http://mozilla.github.io/mozregression/install.html, you will find the section on how to use it on http://mozilla.github.io/mozregression/quickstart.html.

 Please don't hesitate to contact me if you encounter any problems.
Flags: needinfo?(rares.bologa) → needinfo?(ghe)
Hi Bsmedberg, Jorge, SoftVision has flagged this bug as a blocker for esr38.7.1-build1 go-live. Could you please help find an owner who can investigate this issue so we can better understand the next steps? Thanks!
Flags: needinfo?(jorge)
Flags: needinfo?(benjamin)
Tracked for Fx46, 47, 48 and esr38.7
tracking-firefox46: ? → +
tracking-firefox47: ? → +
tracking-firefox48: ? → +
tracking-firefox-esr38: --- → 45+
tracking-firefox-esr45: --- → ?
Canceling NI (just saw BDS's email on r-d) because we are waiting on a regression range.
Flags: needinfo?(jorge)
Flags: needinfo?(benjamin)
Keywords: dev-doc-needed, site-compat
(Reporter)

Comment 20

3 years ago
I'm trying the Mozregression tool.
Flags: needinfo?(ghe)
(Reporter)

Comment 21

3 years ago
After putting the game swf into another place for test, it works:
                http://www.pogo.com/hotdeploy/us/partners/applet/hauntedhog/Main.swf

The original game swf url still fails:
                http://cdn.hauntedhog.prod.pogospike.com/Main.swf

In firebug, both two Urls show the Main.swf is downloaded with status “304 Not Modified”. 

The difference is that in first Url you can see background image on all browsers including Firefox, while in second Url (original one) the image is only shown on IE and Chrome.

Could it be some problems with CDN setting in firefox?
(Reporter)

Comment 22

3 years ago
After following the http://mozilla.github.io/mozregression/quickstart.html, it seems we may mistake the issue caused by browser upgrade. The bug now is reproducing on any version of Firefox
(Reporter)

Comment 23

3 years ago
(In reply to Rivery from comment #22)
> After following the http://mozilla.github.io/mozregression/quickstart.html,
> it seems we may mistake the issue caused by browser upgrade. The bug now is
> reproducing on any version of Firefox

0:48.44 ERROR: Build was expected to be good! The initial good/bad range seems
incorrect.
(In reply to Rivery from comment #23)
> (In reply to Rivery from comment #22)
> > After following the http://mozilla.github.io/mozregression/quickstart.html,
> > it seems we may mistake the issue caused by browser upgrade. The bug now is
> > reproducing on any version of Firefox
> 
> 0:48.44 ERROR: Build was expected to be good! The initial good/bad range
> seems
> incorrect.

Rivery, thanks for taking the time to work on this. As you mention in comment 22, this bug is reproducing on any version of Firefox, so it seems that it is not a regression in Firefox, nor is it a regression in Flash. 
It can be some updates on the pogo.com site. Mozilla is working with pogo to diagnose and fix this issue. 

For the moment, you should not continue investigation with Mozregression tool, because the bug is reproducing on any Firefox version so you will not find any good build.

Comment 25

3 years ago
I'm fairly confident that this is a networking issue of some sort, given the details in comment 21.

I pulled up the network inspector for those two URLs and did a shift-reload and here are the differences in the network response:

WORKING (pogo.com):
Content-Length: "1193921"

NOT-WORKING (cdn.hauntedhog.prod.pogospike.com):
Cache-Control: "private, max-age=326"
Connection: "keep-alive"
Content-Encoding: "gzip"
Content-Length: "1193645"
Vary: "Accept-Encoding"

gzip encoding is pretty common, but it doesn't seem to be buying you much if anything here, so you might want to try getting rid of that to see if it helps.

Next steps: collect a log of the working and non-working URLs using the instructions at https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging

In addition to the networking logs "nsHttp:5,nsSocketTransport:5,nsStreamPump:5,nsHostResolver:5" also include plugin logging: "Plugin:5,PluginNPP:5,PluginNPN:5,IPCPlugins:5"

Rivery is this something you can do? I can help analyze the log files.
Flags: needinfo?(ghe)

Comment 26

3 years ago
Created attachment 8731809 [details]
ff-http-log.txt

http debug log

Comment 27

3 years ago
Created attachment 8731815 [details]
log.txt.child-1

log file with additional plugin params - Plugin:5,PluginNPP:5,PluginNPN:5,IPCPlugins:5

Comment 28

3 years ago
Created attachment 8731817 [details]
log.rar

compressed log file with additional plugin params - Plugin:5,PluginNPP:5,PluginNPN:5,IPCPlugins:5.

Comment 29

3 years ago
Based on this log and some discussion and testing, it's pretty clear that the problem here is related to the gzip decoding of Main.swf.

If you serve the file without Content-Encoding: gzip, it works fine.

We pass these streams directly through to NPAPI without decoding them: it appears that we've always done it this way, and that plugins are responsible for doing their own decoding. So either Flash doesn't support gzip encoding at all, or there is a bug in the Flash gzip decoder.

The only thing that we could do on the Firefox side is intercept these HTTP requests and remove the Accept-Encoding header, either for this specific case or for all plugin-initiated requests. I tend to think doing this in the general case is probably pretty risky, and would be supremely hard to test. So I'm going to resolve this WONTFIX with the expectation that this will be fixed in the pogo CDN.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
status-firefox45: affected → wontfix
status-firefox46: affected → wontfix
status-firefox47: affected → wontfix
status-firefox48: affected → wontfix
status-firefox-esr38: affected → wontfix
status-firefox-esr45: affected → wontfix
Keywords: dev-doc-needed, regression, regressionwindow-wanted, site-compat
(Reporter)

Comment 30

3 years ago
Thank you guys for the information and follow up. We appreciate.
Flags: needinfo?(ghe)
tracking-firefox-esr45: ? → -
You need to log in before you can comment on or make changes to this bug.