startup argument to choose a profile location

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: dougt, Unassigned)

Tracking

Trunk
Future
x86
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
On a set of machines configured for group usage, running mozilla does not save 
profile information.  

The problem is that my "C:\WINNT\Profiles\*user*\Application Data" directory is 
deleted after I log out.  Now, these machines have a HOME directory mapped so 
that I can save my profile.  

What I would like to have is a way that I can start mozilla and pass in the 
directory location of my profile.  

Conrad, do you have objection to this?
(Reporter)

Updated

17 years ago
Severity: normal → enhancement
Target Milestone: --- → Future
This is a feature that is needed on all platforms and OS. The current 
solution under linux to have the profile in .mozilla is not a good one
in many situation either.
There should be a command line option that just lets users specify a new profile
directory and this option should be possible when running the browser,
the profile manager or the profile wizard.

Moving the profile to a different location will often be needed in
corporate environemnts where disk quotas, fast access drives,
network  drives, backup schemes and other stuff is involved.

Another good use would be when a preinstalled mozilla is distributed with
a CDROM and a preconfigured profile. (this would require that mozilla
os able to handle read-only profiles though and should probably be
enabled by another option) 

Updated

17 years ago
Blocks: 124727

Updated

17 years ago
Blocks: 77924
Product: Browser → Seamonkey

Comment 2

13 years ago
*** Bug 315709 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

11 years ago
mass reassigning to nobody.
Assignee: dougt → nobody
QA Contact: ktrina → profile-manager

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.