Closed Bug 1257273 Opened 4 years ago Closed 3 years ago

When selecting text in an iframe that does not have focus, the selection handles appear outside of the iframe

Categories

(Core :: DOM: Selection, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1306634

People

(Reporter: rbarker, Unassigned)

References

(Blocks 1 open bug)

Details

To reproduce go to http://bluemarvin.github.io/html/iframe.html in Fennec. With out giving the iframe focus, long press on a word in the iframe.

Expected results, the word is selected with selection handles.

Actual results, the selection handles appear at the lower left corner of the iframe.

Additionally, if the user long presses again inside of the iframe. While the word is correctly selected with selection handles. The selection handles at the bottom left corner of the iframe do not disappear.
Component: Text Selection → Selection
Product: Firefox for Android → Core
This looks like the AccessibleCaretEventHub of the iframe doesn't receive the long tap event.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1306634
You need to log in before you can comment on or make changes to this bug.