Wrong size of border dashes when using border-radius property

RESOLVED DUPLICATE of bug 382721

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 382721
a year ago
a year ago

People

(Reporter: GibboK, Unassigned)

Tracking

({testcase})

44 Branch
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8731578 [details]
2016-03-17 09_05_04-Edit fiddle - JSFiddle.png

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.87 Safari/537.36

Steps to reproduce:

Test case:
https://jsfiddle.net/f8g4quv1/

- Create a DIV
- Apply CSS width/height and background-color
- Apply CSS border dashed
- Apply CSS border-radius


Actual results:

Border dashed lines near in the corners have DIFFERENT length that on the sides.
Screenshot attached, it shows issue in Firefox on the left side compare with Chrome 49.0.2623.87 m on the right side.


Expected results:

Border dashed lines near in the corners should have SAME length as other sides (Similarly to Chrome).
(Reporter)

Comment 1

a year ago
Issue happens with or without applying box-sizing: border-box;

Example:

https://jsfiddle.net/f8g4quv1/2/
(Reporter)

Comment 2

a year ago
SO related: http://stackoverflow.com/questions/36055372/dashed-border-with-applied-border-radius-have-wrong-length-in-firefox

Comment 3

a year ago
Created attachment 8731735 [details]
1257447.html

Updated

a year ago
Component: Untriaged → Layout
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Keywords: testcase
Resolution: --- → DUPLICATE
Duplicate of bug: 382721
You need to log in before you can comment on or make changes to this bug.