Closed Bug 1257479 Opened 5 years ago Closed 5 years ago

Fix IMMHandler.cpp compilation with GCC.

Categories

(Core :: Widget: Win32, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1137561
Tracking Status
firefox48 --- affected

People

(Reporter: jacek, Assigned: jacek)

Details

Attachments

(1 file)

Attached patch fixSplinter Review
I get:

widget/windows/IMMHandler.cpp: In member function ‘mozilla::widget::TextEventDispatcher* mozilla::widget::IMMHandler::GetTextEventDispatcherFor(nsWindow*)’:
widget/windows/IMMHandler.cpp:1268:53: error: operands to ?: have different types ‘RefPtr<mozilla::widget::TextEventDispatcher>’ and ‘nsIWidget::TextEventDispatcher* {aka mozilla::widget::TextEventDispatcher*}’
   return aWindow == mComposingWindow && mDispatcher ?
                                                     ^
widget/windows/IMMHandler.cpp:1268:53: note:   and each type can be converted to the other

on mingw.
Attachment #8731625 - Flags: review?(m_kato)
I already landed as http://hg.mozilla.org/integration/mozilla-inbound/rev/22b32ab5ce8f.  Do you still fail on the latest m-i?
I missed that, I was testing with m-c. Sorry about that.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1137561
No longer blocks: 1137561
Attachment #8731625 - Flags: review?(m_kato)
You need to log in before you can comment on or make changes to this bug.