Login broken when no redirect

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mcote, Assigned: mcote)

Tracking

Production

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
Saw this error in the logs:

'NoneType' object has no attribute 'find'
Traceback (most recent call last):
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/django/core/handlers/base.py", line 112, in get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)
  File "/usr/lib64/python2.6/site-packages/newrelic-2.44.0.36/newrelic/hooks/framework_django.py", line 497, in wrapper
    return wrapped(*args, **kwargs)
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/mozreview-0.1.2a0-py2.6.egg/mozreview/views.py", line 35, in bmo_auth_callback
    return get_bmo_auth_callback(request)
  File "/data/www/reviewboard.mozilla.org/venv/lib/python2.6/site-packages/mozreview-0.1.2a0-py2.6.egg/mozreview/views.py", line 98, in get_bmo_auth_callback
    parsed = urlparse.urlparse(redirect)
  File "/usr/lib64/python2.6/urlparse.py", line 132, in urlparse
    tuple = urlsplit(url, scheme, allow_fragments)
  File "/usr/lib64/python2.6/urlparse.py", line 171, in urlsplit
    i = url.find(':')
AttributeError: 'NoneType' object has no attribute 'find'
(Assignee)

Comment 1

3 years ago
This was caused by http://hg.mozilla.org/hgcustom/version-control-tools/rev/415a3d6628d3 (bug 1254241).  I tested the case where redirect is an empty string, but not when it's None.
(Assignee)

Comment 2

3 years ago
Created attachment 8731840 [details]
MozReview Request: mozreview: Fix login when no redirect parameter is used (bug 1257634). r?smacleod

Review commit: https://reviewboard.mozilla.org/r/40871/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/40871/
Attachment #8731840 - Flags: review?(smacleod)
Comment on attachment 8731840 [details]
MozReview Request: mozreview: Fix login when no redirect parameter is used (bug 1257634). r?smacleod

https://reviewboard.mozilla.org/r/40871/#review37383
Attachment #8731840 - Flags: review?(smacleod) → review+
(Assignee)

Comment 4

3 years ago
This was fixed and deployed a few days ago.

http://hg.mozilla.org/hgcustom/version-control-tools/rev/de737936b4f1
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.