Closed Bug 1257932 Opened 4 years ago Closed 4 years ago

Enable test_continuous_wheel_events.html with e10s

Categories

(Core :: DOM: Events, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1251905
Tracking Status
firefox48 --- affected

People

(Reporter: mccr8, Unassigned)

References

Details

No description provided.
I wrote some patches for this test, which looks straightforward. However, there must be some remaining raciness in there. Occasionally the test will hang, and when it doesn't hang, often there will be 1 to 10 or so failures like this:

testContinuousTrustedEvents, Horizontal wheel event by pixels (-5.3 - 0) #2: wheel event target was invalid - got [object HTMLHtmlElement], expected [object HTMLDivElement]

eg the target is the wrong kind of element. Very odd.
No longer depends on: 1251905
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1251905
You need to log in before you can comment on or make changes to this bug.