Closed Bug 12580 Opened 21 years ago Closed 20 years ago

Implement URL Dispatching

Categories

(SeaMonkey :: UI Design, defect, P3)

All
Other
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 14928

People

(Reporter: warrensomebody, Assigned: mscott)

References

Details

This is the problem where imap links in the browser want to be handled by mail,
and http links in mail want to be handled by the browser, etc. (formerly know
as the "event sink getter" problem -- but now we understand that that's just a
piece of it).

The high-level requirements for this are that the mechanism be extensible and
hot hard-wired to particular protocols/mime-types/applications.

Radha has the latest write-up on this:
news://news.mozilla.org/37C48F1E.40E3049C%40netscape.com
*** Bug 8628 has been marked as a duplicate of this bug. ***
QA Contact: beppe → paulmac
Blocks: 12833
Doug Turner contacted me today regarding .xpi files. He needs to be able to
"intercept" .xpi files (installer files) when user clicks on them.
Blocks: 12659
Blocks: 13465
No longer blocks: 12659
*** Bug 14669 has been marked as a duplicate of this bug. ***
Shouldn't this be mscott's, or a DUP of an mscott bugs 14927 and 14928?  Maybe
this should be the meta-bug that depends on those.

/be
Depends on: 14927, 14928
*** Bug 15849 has been marked as a duplicate of this bug. ***
Assignee: rpotts → mscott
Scott should own this now.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 14928 ***
No longer blocks: 13465
Status: RESOLVED → VERIFIED
Mark it Verified/Dup.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.