Closed Bug 12582 Opened 21 years ago Closed 21 years ago

Milestone 9 won't work with Sun JDK 1.3beta

Categories

(Core :: JavaScript Engine, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 5369

People

(Reporter: macherius, Assigned: malini)

Details

<subject> says about all. My machine is WinNT(client,german,4.0,SP5). The
JDK that runs into problems is Sun Jdk 1.3beta. My Mozilla is Milestone 9.

Problem: The Sun JVM 1.3beta is not recognized correctly, and afterwards
strange things happen.

Note: "Java ist nicht aktiviert" translates "Java is not activated".

Here is the output when starting "apprunner.exe":

D:\mozilla\m9\bin>D:\mozilla\m9\bin\apprunner.exe
Profile Manager : Command Line Options : Begin
Profile Manager : Command Line Options : End
Profile Manager : Profile Wizard and Manager activites : Begin
Profile Manager : Profile Wizard and Manager activites : End
Java(TM) HotSpot Client VM warning: Setting of property "java.compiler" is ignor
ed
Java ist nicht aktiviert
initialization error: Can't load class netscape/javascript/JSUtil
initialization error: Can't read static field java.lang.Void.TYPE
Toolbar registered as Drag Listener
Toolbar registered as Drag Listener
failed to get sidebar_pref
Doing Startup...
Creating browser app core
BrowserAppCore has been created.
Setting content window
browser.startup.page = 1
startpage = http://www.mozillazine.org/
JavaScript error: Package java defined twice ?



Recieving ... /5895=,CFC-2857.1; path=/
Document http://www.mozillazine.org/ loaded successfully
Document: Done (12.708 secs)
OS: other → Windows NT
Component: Java FrontEnd → Javascript Engine
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 5369 ***
Verified dupe of bug 5369
Crash on startup because of Java Plug-in 1.3 for Netscape Navigator.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.