Last Comment Bug 125828 - Find doesn't report when end is reached.
: Find doesn't report when end is reached.
Status: RESOLVED DUPLICATE of bug 100631
:
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Asa Dotzler [:asa]
: Doron Rosenberg (IBM)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-15 18:04 PST by Michael Bacarella
Modified: 2007-12-10 13:34 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Michael Bacarella 2002-02-15 18:04:22 PST
Before you mark this as a duplicate, hear me out.

Head to http://www.mozilla.org/bugs/

Find 'report'. (Don't check 'Search Backwards'). Good. Now keep finding it until
it says "The text you entered was not found". It says this when you reach the
end. If you scroll the window to the top (but leave the last instance of
"report" selected) and try searching again, it will tell you the text wasn't found.

Until you click some part of the page, the search will continue from the last
highlighted entry. If it's the last one on the page, it won't tell you that,
simply that it wasn't found. Very confusing.

You could either announce when the search has reached the end of the page or
start the search from wherever the browser is positioned rather than which part
of the page is selected.

Using Mozilla 0.9.8 on Linux.
Comment 1 R.K.Aa. 2002-02-15 18:52:54 PST
i agree. As i see it, the current implementation of search on page is near
useless and Always annoying.

Even if i don't click in page but only have scrolled there, a new search will
miss a lot of possible hits, because it starts the search from "viewport" and
not above it. I can't count the number of times this caused me loose a "good
hit", and now, when i've learned to always click "wrap" first, I'm never quite
sure exactly where it wrapped the search, so i waste time searching more than
strictly needed, till i'm 100% sure all of the page has been searched.

One of the many bugs about this was 17991, with 7 dups. There are many more.
Why the excellent search behaviour from NS4 isn't used is completely beyond me.
Comment 2 Andrew Schultz 2002-02-16 17:44:49 PST
the current behavior is not all that bad.  with wrap on, you may not know when
the whole page has been searched, but you definitely know when the end has been
reached (which seems to be the point here).  if the current "view" is used, then
scrolling while searching would make "search next" meaningless.  the message
that "The text you entered was not found" might be confusing the first time, but
is ok after that.

> it starts the search from the "viewport" and not above it.

I don't understand what you mean

most of bug #17991 was adding *any* indication of failure.

the current behavior is not perfect, and the NS4 behavior would probably be an
improvement, but the way it is now is far from 'near useless' or 'always annoying'

the component for this is XP Apps: GUI Features
Comment 3 Jesse Ruderman 2002-02-23 17:50:23 PST
>Even if i don't click in page but only have scrolled there, a new search will
>miss a lot of possible hits, because it starts the search from "viewport" and 
>not above it.

rkaa, I don't see that.  I tried searching slashdot.org (light mode) just now, 
and Mozilla started searching from the top of the page, not from the top of the 
part of the page visible on the screen.  I think searching from the top of the 
page is correct, because with complex layouts it's hard to tell what "part of 
the page" the top of the viewport corresponds to.

Anyway, I think this is a dup of bug 100631, Find/Replace doesnt ask "End of 
document reached, continue from beginning?".

*** This bug has been marked as a duplicate of 100631 ***

Note You need to log in before you can comment on or make changes to this bug.