Closed Bug 1259001 Opened 6 years ago Closed 5 years ago

Eyedropper color-value-box should be displayed in visible position

Categories

(DevTools :: Inspector, defect, P3)

defect

Tracking

(firefox45 affected, firefox46 affected, firefox47 affected, firefox48 affected, firefox-esr45 affected)

RESOLVED DUPLICATE of bug 1289553
Tracking Status
firefox45 --- affected
firefox46 --- affected
firefox47 --- affected
firefox48 --- affected
firefox-esr45 --- affected

People

(Reporter: magicp.jp, Unassigned)

Details

(Whiteboard: [btpp-backlog])

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160322030417

Steps to reproduce:

1. Start any versions Firefox
2. Maximize the window
3. Start Eyedropper
4. Move around the window


Actual results:

Eyedropper color-value-box with position invisible.


Expected results:

Eyedropper color-value-box should be displayed in visible position.
Has STR: --- → yes
Component: Untriaged → Developer Tools: Inspector
OS: Unspecified → All
Hardware: Unspecified → All
Thanks for filing.
This would be a useful enhancement indeed. 
We do something a little bit similar with the node-info-bar (the dark bubble that contains the current element's tagname and attributes when you highlight elements in the page), where we try and display it where it would be visible, even if the corresponding element is partly or completely off-screen.
So we should do something like this for the eyedropper too.
Priority: -- → P3
Whiteboard: [btpp-backlog]
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1289553
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.