Using 45.0.1 Firefox starts up using about 235MB mem/VM (taskmanager) as I open and close new tabs memory rises and falls, but overall keeps increasing until my system grinds to a total halt. Memory Leak???

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: gpage, Unassigned)

Tracking

45 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160315153207

Steps to reproduce:

Using Firefox 45.0.1 on Win XP SP3 with 1GB of RAM.
Opened Firefox, and browsed various web pages opening and closing various tabs as I go.



Actual results:

Opening new tabs took extra memory, closing tabs released some but not all extra memory previously allocated. Over a period memory use increased from starting 235MB
to over 500MB by which time Firefox (and my system in general) started to become unresponsive (probably because of page file accessing I suspect).



Expected results:

I would have expected Firefox to efficiently release memory when tabs are closed. It might return to its opening memory size, but it shouldn't keep climbing.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows XP
Hardware: Unspecified → x86

Comment 1

3 years ago
500 MB of memory use for Firefox is "standard" in general. Honestly, 1 GB of RAM is not enough with modern browsers and web, especially if you have many other applications running at the same time (plus the OS memory footprint). Outdated OS and limited hardware, don't expect too much.
Whiteboard: [MemShrink]

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.