-moz-box children with position:relative move permanently on hover

REOPENED
Unassigned

Status

()

Core
Layout
REOPENED
2 years ago
2 years ago

People

(Reporter: henriksnes, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8734350 [details]
reporter's testcase (only reproduces in builds without webkit prefix support)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.87 Safari/537.36

Steps to reproduce:

1. Load up the provided index.html in Firefox 45.0.1
2. Hover over either of the two sections


Actual results:

The <section> will move up, and never come back down. Hovering over it again will make it move further up.


Expected results:

When the hover ends, the hover rule, top:-10px, should stop taking effect, and the <section> should come back down to its original position.

This bug seems to be fixed in the latest trunk, but I didn't see any bug reports about it, so I'm submitting it in case it might lead to a regression test that prevents it from regressing again.

Updated

2 years ago
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core

Updated

2 years ago
Blocks: 1213126
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
This isn't related to bug 1213126 [removing "blocks" relationship], and it's not fixed -- it's just a bug that specifically affects "display:-moz-box" elements. (and this particular testcase happens to have its moz-box styling suppressed if we enable webkit prefix support)

I'll attach a testcase that still reproduces this in Nightly, without any webkit stuff.
No longer blocks: 1213126
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
Created attachment 8735511 [details]
reduced testcase 1
Attachment #8734350 - Attachment description: index.html → reporter's testcase (only reproduces in builds without webkit prefix support)
Component: CSS Parsing and Computation → Layout
Summary: Flexbox-children with position:relative move permanently on hover → -moz-box children with position:relative move permanently on hover
Version: 45 Branch → Trunk
You need to log in before you can comment on or make changes to this bug.