Closed Bug 1259575 Opened 5 years ago Closed 5 years ago

Show more entries in the awesomebar popup

Categories

(Firefox :: Address Bar, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1195054
Tracking Status
firefox48 --- affected

People

(Reporter: adw, Unassigned)

References

Details

(In reply to Stephen Horlander [:shorlander] from bug 1181078 comment #41)
> (In reply to Marco Bonardo [::mak] from comment #40)
> > (In reply to Guillaume C. [:ge3k0s] from comment #39)
> > > -With the smaller entries it would be nice having more of them shown by
> > > default and at the same time finally getting rid of this useless scroll bar.
> > 
> > It will happen in a followup. we didn't decide whether we'll go to 8 or 10
> > results (I'd vote to start with 10 and then use telemetry to tweak it.)
> 
> Yes, I think 10 would be a good place to start. Do we have a bug for this
> already? I can file one if not.
Shell mentioned that in the past we'd looked at the question of how many results to show.  There is bug 583683.  It's pretty old and has some good comments.  There's also bug 775825, which added telemetry for the selected awesomebar result.
Just to take that into account, we have consts defined in the code that make us show at least 6 local results http://mxr.mozilla.org/mozilla-central/source/toolkit/components/places/UnifiedComplete.js#74 and remaining results can (if they are below FRECENCY_DEFAULT) be taken by search suggestions.

That's in addition to the heuristic result, that brings items to 7.

That means the original intent to show 8 results, in some cases, would have shown only the first search suggestion, while we may want to show more of them, cause they could be quite useful.

And that's how we reached a consensus around 10, so in common cases we have 1 heuristic, 6 local and 3 suggestions.
Blocks: 1262507
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1195054
You need to log in before you can comment on or make changes to this bug.