Clean up WidgetSimpleGestureEvent

RESOLVED FIXED in Firefox 49

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: masayuki, Assigned: tetsuharu, Mentored)

Tracking

(Blocks 1 bug)

Trunk
mozilla49
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 affected, firefox49 fixed)

Details

(Whiteboard: [good first bug][for Gecko Inside #7 in Mozilla Japan])

Attachments

(5 attachments)

I'll take this.
Assignee: nobody → saneyuki.s.snyk
Status: NEW → ASSIGNED
Thanks. Could you move |double delta;| to the first or the last member too? The instance size must be same or increased from current size. But adding new member would be bad if we kept current order (e.g., adding new double member or uint64_t to the tail with current order).
Comment on attachment 8742139 [details]
MozReview Request: Bug 1259667 - part1: reorder the padding of WidgetSimpleGestureEvent.r?masayuki

https://reviewboard.mozilla.org/r/46943/#review44015
Attachment #8742139 - Flags: review?(masayuki) → review+
Comment on attachment 8742140 [details]
MozReview Request: Bug 1259667 - part2: rename WidgetSimpleGestureEvent.allowedDirections to mAllowedDirections. r?masayuki

https://reviewboard.mozilla.org/r/46945/#review44017
Attachment #8742140 - Flags: review?(masayuki) → review+
Comment on attachment 8742141 [details]
MozReview Request: Bug 1259667 - part3: rename WidgetSimpleGestureEvent.direction to mDirection. r?masayuki

https://reviewboard.mozilla.org/r/46947/#review44019
Attachment #8742141 - Flags: review?(masayuki) → review+
Comment on attachment 8742142 [details]
MozReview Request: Bug 1259667 - part4: rename WidgetSimpleGestureEvent.clickCount to mClickCount. r?masayuki

https://reviewboard.mozilla.org/r/46949/#review44021
Attachment #8742142 - Flags: review?(masayuki) → review+
Comment on attachment 8742143 [details]
MozReview Request: Bug 1259667 - part5: rename WidgetSimpleGestureEvent.delta to mDelta. r?masayuki

https://reviewboard.mozilla.org/r/46951/#review44027

::: widget/cocoa/nsChildView.mm:4253
(Diff revision 1)
>      return;
>    }
>  
>    // Setup the event.
>    WidgetSimpleGestureEvent geckoEvent(true, msg, mGeckoChild);
> -  geckoEvent.delta = deltaZ;
> +  geckoEvent.mDelta = deltaZ;

Interesting, using deltaZ...
tetsuharu-san, it fails to land the patches with autoland, could you rebase the patches, do |hg push review| again and kick the autoland from ReviewBoard?
Flags: needinfo?(saneyuki.s.snyk)
Comment on attachment 8742139 [details]
MozReview Request: Bug 1259667 - part1: reorder the padding of WidgetSimpleGestureEvent.r?masayuki

Review request updated; see interdiff: https://reviewboard.mozilla.org/r/46943/diff/1-2/
Comment on attachment 8742140 [details]
MozReview Request: Bug 1259667 - part2: rename WidgetSimpleGestureEvent.allowedDirections to mAllowedDirections. r?masayuki

Review request updated; see interdiff: https://reviewboard.mozilla.org/r/46945/diff/1-2/
Comment on attachment 8742141 [details]
MozReview Request: Bug 1259667 - part3: rename WidgetSimpleGestureEvent.direction to mDirection. r?masayuki

Review request updated; see interdiff: https://reviewboard.mozilla.org/r/46947/diff/1-2/
Comment on attachment 8742142 [details]
MozReview Request: Bug 1259667 - part4: rename WidgetSimpleGestureEvent.clickCount to mClickCount. r?masayuki

Review request updated; see interdiff: https://reviewboard.mozilla.org/r/46949/diff/1-2/
Comment on attachment 8742143 [details]
MozReview Request: Bug 1259667 - part5: rename WidgetSimpleGestureEvent.delta to mDelta. r?masayuki

Review request updated; see interdiff: https://reviewboard.mozilla.org/r/46951/diff/1-2/
I'm sorry to replay late. I just updated patches.
Flags: needinfo?(saneyuki.s.snyk)
You need to log in before you can comment on or make changes to this bug.