Closed Bug 1259827 Opened 5 years ago Closed 5 years ago

[e10s] Crash during deserialization of MaybeNativeKeyBinding

Categories

(Core :: DOM: Content Processes, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1258312
Tracking Status
e10s + ---
firefox48 --- affected

People

(Reporter: mccr8, Unassigned)

References

Details

(Keywords: crash)

Crash Data

I came across this crash while looking at crash-stats:

https://crash-stats.mozilla.com/report/index/44723b21-3f83-4042-ae7c-391902160324

It is crashing in mozilla::dom::PBrowserChild::Read(mozilla::dom::MaybeNativeKeyBinding*, IPC::Message const*, void**). It looks like it is crashing during the deserialization of the tag int on the union, which is odd. That is all IPDL generated code that is running. I can't see anything obviously wrong with it.

This looks similar to bug 1258312, but it is much less common, so it probably isn't worth tracking individual. I just thought it would be good to have another deserialization crash on file in case there is some broader issue.
Blocks: e10s-crashes
tracking-e10s: --- → +
Priority: -- → P3
No longer blocks: e10s-crashes
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1258312
You need to log in before you can comment on or make changes to this bug.