SeaMonkey trunk not building due to outdated gcc (need 4.8.x)

RESOLVED DUPLICATE of bug 1190773

Status

RESOLVED DUPLICATE of bug 1190773
3 years ago
3 years ago

People

(Reporter: ewong, Assigned: ewong)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
We still use 4.7.x and post-bug-1175546 tree, we need to use
4.8.x

What needs to be done are the following:

1) Update our linux32/64 tooltool to use the right gcc version.
2) Add the tooltool package of that gcc version to our tooltool repo.
(Assignee)

Comment 1

3 years ago
Created attachment 8735661 [details] [diff] [review]
[tooltool] change to use gcc 4.8.5 package.
Assignee: nobody → ewong
Status: NEW → ASSIGNED
Attachment #8735661 - Flags: review?(bugspam.Callek)
(Assignee)

Comment 2

3 years ago
(In reply to Edmund Wong (:ewong) from comment #0)
> We still use 4.7.x and post-bug-1175546 tree, we need to use
> 4.8.x
> 
> What needs to be done are the following:
> 
> 1) Update our linux32/64 tooltool to use the right gcc version.
> 2) Add the tooltool package of that gcc version to our tooltool repo.

With the chance that our tooltool repo could get decommissioned soon,
there's little point in doing #2.  I think bug 1190773 will need to be
fixed before this bug can be fixed.
Depends on: 1190773

Updated

3 years ago
status-firefox48: affected → ---

Comment 3

3 years ago
Comment on attachment 8735661 [details] [diff] [review]
[tooltool] change to use gcc 4.8.5 package.

r=me if you add
"version": "gcc 4.8.5"
and
"unpack": true
to the manifests. (assuming unpack true is needed)
Attachment #8735661 - Flags: review?(bugspam.Callek) → review+
(Assignee)

Comment 4

3 years ago
(In reply to Philip Chee from comment #3)
> Comment on attachment 8735661 [details] [diff] [review]
> [tooltool] change to use gcc 4.8.5 package.
> 
> r=me if you add
> "version": "gcc 4.8.5"
> and
> "unpack": true
> to the manifests. (assuming unpack true is needed)

Unpack is needed.  btw, could you also review the tooltool
patches on bug 1190773?
(Assignee)

Comment 5

3 years ago
Having given some thought, I think this bug is silly.  Might as well put all
those changes in bug 1190773. 

So this problem will be fixed in bug 1190773.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1190773
You need to log in before you can comment on or make changes to this bug.