Closed Bug 1260140 Opened 6 years ago Closed 6 years ago

Copy an html table from firefox v45, paste into seamonkey v2.40 composer, only got table content, not table itself

Categories

(SeaMonkey :: Composer, defect)

SeaMonkey 2.40 Branch
Unspecified
Windows 7
defect
Not set
minor

Tracking

(seamonkey2.41?, seamonkey2.42?, seamonkey2.43?, seamonkey2.44?, seamonkey2.46 fixed)

RESOLVED DUPLICATE of bug 1254980
Tracking Status
seamonkey2.41 ? ---
seamonkey2.42 ? ---
seamonkey2.43 ? ---
seamonkey2.44 ? ---
seamonkey2.46 --- fixed

People

(Reporter: s793016, Unassigned)

Details

(Keywords: reproducible, Whiteboard: dupme)

Attachments

(1 file)

3.19 KB, application/save-as
Details
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40
Build ID: 20160120202951

Steps to reproduce:

Sorry, my English is very very poor.

Acturally this may not caused by seamonkey.

When copy html table frome firefox v45, and paste it into seamonkey v2.4 composer, you get only table content.

When copy html table frome firefox v44 and below, and paste it into seamonkey v2.4 composer, you get the table correctly.

1.goto here:
http://www.htmlgoodies.com/tutorials/tables/article.php/3479851

2.copy a table

3.paste it into seamonkey composer


Actual results:

u got contents of table (divided by tab).


Expected results:

u got a whole table with table element.
I tried to copy html table from firefox v45 and paste it into word 2003 / excel 2003,

word and excel get the table correctly with table elements.
NOT reproducible  with  en-US SeaMonkey 2.40 final Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) from official download page,  Gecko/20100101  Firefox/ 43.0  Build 20160120202951, (Classic Theme) on German WIN7 64bit

0. Launch SM Composer with new, empty document
1. Open <http://www.htmlgoodies.com/tutorials/tables/article.php/3479851> in 
   FF 48.0a1 (2016-03-27)
2. In Table with top left cell "Marcia" 'click left from "Marcia" → 
   With pushed left Mouse button move mouse pointer right from "Bobby" so that
   all table contents becomes highlighted → release mouse button'
3. 'Rightclick on "Bobby" → Copy'
4. 'Switch to Composer document (Normal View tab) → Rightlick  → Paste'
   » As expected complete Table with contents appears
   
a) FF 45 related due to original report? 
b) Particular problem with reporter's system?

@Reporter: Thank you for your attention. 
Please contribute more precise information!
a) Contribute a problem related step by step instruction containing every 
   key press and every mouse click how to reproduce your problem due to 
   <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>
   (similar to report in Bug 1139273)
b) Attach screenshots with comments if you believe that that might explain the 
   problem better than a text comment. Best way is to insert your screenshots
   into a OOo or LibreOffice DRAW document and to add comments 
   that explain what you want to show (attach .png or PDF from source document)
c) add information 
c1) concerning your Operating System (Version, Distribution, Language)
c2) concerning your SM localization (UI language, Locale setting)
c3) SM settings that might be related to your problems 
    May be you should attach a copy of menu 
   'Help → Trouble shooting information”
c4) how you launch SM (Double click on document? console? …)
c5) Whether problem persists in safe mode without add-ons
c6) Whether problem persists with blank new profile
c7) everything else crossing your mind after you read linked texts
d)  Attachment with Composer result and WORD result documents (together as .zip)
Flags: needinfo?(s793016)
Thanks for the demo.

with  en-US SeaMonkey 2.40 final Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) from official download page,  Gecko/20100101  Firefox/ 43.0  Build 20160120202951, (Classic Theme) on TradChinese WIN7 64bit

test with ff47:
0. Launch SM Composer with new, empty document
1. Open <http://www.htmlgoodies.com/tutorials/tables/article.php/3479851> in 
   FF 47.0a2 (https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-aurora-l10n/firefox-47.0a2.zh-TW.win32.installer.exe)
2. In Table with top left cell "Marcia" 'click left from "Marcia" → 
   With pushed left Mouse button move mouse pointer right from "Bobby" so that
   all table contents becomes highlighted → release mouse button'
3. 'Rightclick on "Bobby" → Copy'
4. 'Switch to Composer document (Normal View tab) → Rightlick  → Paste'
   » As expected complete Table with contents appears

test with ff46:
0. Launch SM Composer with new, empty document
1. Open <http://www.htmlgoodies.com/tutorials/tables/article.php/3479851> in 
   FF 46.0b5 (https://download.mozilla.org/?product=firefox-46.0b5-SSL&os=win&lang=en-US)
2. In Table with top left cell "Marcia" 'click left from "Marcia" → 
   With pushed left Mouse button move mouse pointer right from "Bobby" so that
   all table contents becomes highlighted → release mouse button'
3. 'Rightclick on "Bobby" → Copy'
4. 'Switch to Composer document (Normal View tab) → Rightlick  → Paste'
   » u got contents of table (divided by tab).

test with ff45:
0. Launch SM Composer with new, empty document
1. Open <http://www.htmlgoodies.com/tutorials/tables/article.php/3479851> in 
   FF 45.0.1 (https://download.mozilla.org/?product=firefox-45.0.1-SSL&os=win&lang=en-US)
2. In Table with top left cell "Marcia" 'click left from "Marcia" → 
   With pushed left Mouse button move mouse pointer right from "Bobby" so that
   all table contents becomes highlighted → release mouse button'
3. 'Rightclick on "Bobby" → Copy'
4. 'Switch to Composer document (Normal View tab) → Rightlick  → Paste'
   » u got contents of table (divided by tab).
Flags: needinfo?(s793016)
I am not sure what Comment 3 tells. Seems that only copy / paste from FF 47 for reporter has the epected result?

I did some additional tests, aways WIN7, always using my normal profile:

a): Always followed Steps from Comment 1 to do a copy/paste from FF and other 
    Browsers
e) For paste to SM Composer results see “Test Results SM240.html”, from any
   other Browser pasted result is a table, only from FF45 result are text lines
   with “&nbsp;” (unbreakable Space) separated strings
f) For paste to AOO.html results see “Test Results SM240.html”, from any
   Browser pasted result is a table, nothing special with FF 45
g) Not a new effect, already visible with composer of SM 2.35
h) Also SM2.40 e-mail composing (html) affected
i) Clipboard contents (see attached test kit) and clipbrd.exe pasted to
   composer document shows following results
i1) clipboard contents from both sources (see test kit) show damaged table 
    contents in SM 2.40 Composer, but real table in AOO.html
k) I tried some other html-copy-paste using WORDPRESS wp-admin- new posting
   (you can easily create a new account at
    <https://wordpress.com/start/website/survey/>) - wysiwg-view, copy from
   source page in FF45
k1) Paste into WP WYSIWYG editor results in Table with WP target in IE11, FF45
k2) Paste into WP WYSIWYG editor results in text lines with “&nbsp;” 
    (unbreakable Space) separated strings  in SM 2.45, CLIQZ
l) New situation with English SeaMonkey 2.45a1  (Windows NT 6.1; WOW64; rv:48.0)
   Gecko/20100101 Firefox/48.0 Build 20160308001946  (Default Classic Theme)  
   on German WIN7 64bit:
   Test (k) works fine now pasting to SM 2.45 browser WP edit, shows table.
   Also progress for HTML-web-page composer and e-mail: Table shown, but 
   strinG “marica” shown before table. Fist table cell is empty.
   This “marcia” issue is a new bug, I will submit a separate report.
m) The copy from ff45, paste to SM  -  issue is not limited to the sample table
   form the test source page, but a general problem, for example try to 
   copy table in <https://unofficialseamonkeynews.wordpress.com/2016/03/30/qa-statistics-for-old-seamonkey-bugs/> and paste to SM 2.40 composer, mail, 
   WP-Edit: always the same bad result.
n) My conclusion: SM < 2.48 paste function has a problem with particular 
   html-table-clipboard-contents, currently only known clipboard source 
   causing this problem is FF 45
   MINOR because currently problem seems limited to very particular conditions

@tony:
Can you please try with linux?
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Windows 7
Attached file Test Kit
see comment above how to use
This one probably is a DUP of "Bug 1254980 - Copy-pasting selected HTML from Firefox to a new Thunderbird message (using TB 38) or to BlueGriffon is broken as of Firefox 45"
Status: NEW → UNCONFIRMED
Ever confirmed: false
Keywords: reproducible
Whiteboard: dupme
Probably all SM Versions until 2.44 affected, fixed for 2.45
UP of "Bug 1254980 - Copy-pasting selected HTML from Firefox to a new Thunderbird message (using TB 38) or to BlueGriffon is broken as of Firefox 45" for now.

@Reporter: 
Please feel free to reopen this Bug if you find out that the fix for the other bug does not solve your problem (With SM 2.45 and later) or if you see other well founded indication that you fond an independent bug.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1254980
You need to log in before you can comment on or make changes to this bug.