crash in java.lang.NoClassDefFoundError: android.util.AtomicFile at org.mozilla.gecko.dlc.catalog.DownloadContentCatalog.<init>(DownloadContentCatalog.java)

RESOLVED DUPLICATE of bug 1256427

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 1256427
2 years ago
2 years ago

People

(Reporter: kbrosnan, Assigned: sebastian)

Tracking

(Blocks: 1 bug, {crash})

unspecified
All
Android
crash
Points:
---

Firefox Tracking Flags

(fennec48+)

Details

(crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-8262dd10-d773-48ec-83fb-865782160325.
=============================================================

This is a crash on startup. Uptimes are empty or 1 to 15 seconds.


java.lang.NoClassDefFoundError: android.util.AtomicFile
	at org.mozilla.gecko.dlc.catalog.DownloadContentCatalog.<init>(DownloadContentCatalog.java:44)
	at org.mozilla.gecko.dlc.DownloadContentService.onCreate(DownloadContentService.java:59)
	at android.app.ActivityThread.handleCreateService(ActivityThread.java:2504)
	at android.app.ActivityThread.access$1600(ActivityThread.java:149)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1382)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:153)
	at android.app.ActivityThread.main(ActivityThread.java:5086)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:821)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:584)
	at dalvik.system.NativeStart.main(Native Method)
(Assignee)

Comment 1

2 years ago
In bug 1256427 we replaced the support library version of AtomicFile with the framework version. This crash is on API 16 and looking at Android's docs AtomicFile is API 17+. Seems like this was an error.
Flags: needinfo?(michael.l.comella)
(Assignee)

Updated

2 years ago
Assignee: nobody → s.kaspari
(Assignee)

Comment 2

2 years ago
Seems like this backout has already happened. We shouldn't see those crashes anymore:
https://hg.mozilla.org/integration/fx-team/rev/5e287404e4f8fd81330cd704e42fba5e3baa5f49
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1256427
Flags: needinfo?(michael.l.comella)

Updated

2 years ago
tracking-fennec: ? → 48+
You need to log in before you can comment on or make changes to this bug.