Closed Bug 1260490 Opened 3 years ago Closed 3 years ago

webextension popup can't be closed

Categories

(WebExtensions :: Untriaged, defect)

45 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1190663

People

(Reporter: carlos, Unassigned)

References

Details

(Keywords: addon-compat)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.87 Safari/537.36

Steps to reproduce:

create a webextension with a popup
call window.close()


Actual results:

error in console:
"Scripts may not close windows that were not opened by script."


Expected results:

The extension popup should close
Keywords: addon-compat
Component: Untriaged → WebExtensions
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1190663
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.