Closed Bug 1260504 Opened 4 years ago Closed 3 years ago

self.marionette.restart() should not reset preferences as set before the restart

Categories

(Testing :: Marionette, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1373635

People

(Reporter: whimboo, Unassigned)

References

(Blocks 1 open bug)

Details

As of now the restart() method always resets any modified preference. This won't work for any restart test which relies on preferences set from before the restart. For example see bug 1237396 comment 54. There we have preferences which have to be set when Firefox starts and cannot be modified when the test continuous.

We should ensure that restart() keeps any modified preference so we can simulate a real Firefox restart. Letting Marionette modify any of those preferences would kill our capability to execute those restart tests.
So we have enforce_gecko_prefs() to keep preferences values permanently. This method looks still strange to me because it always wants to restart the browser whereby most of the prefs we set here would not require a restart. I think we should refactor this method:

* Add an optional restart argument to request a restart if necessary for both in_app and forced restart. 
* Fix context setting; right now we always end-up with content context 
* Make use of the get_pref() method from the Marionette class to fix the issue with different types (3 != '3')
* Update and add more tests in test_profile_management.py
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1373635
You need to log in before you can comment on or make changes to this bug.