Windows are sometimes restored in a wrong position outside of the screen

RESOLVED WORKSFORME

Status

()

Core
Widget: Gtk
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: marco, Unassigned)

Tracking

({regression})

48 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox47 unaffected, firefox48 fix-optional, firefox49 affected, firefox50 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Sometimes, a window gets restored in a wrong position outside of the screen, which makes it impossible to use it again.

I'm attaching a video of the situation after this has happened (I can't access the restored window anymore).

This might be somehow related to bug 1251217.
(Reporter)

Updated

2 years ago
Summary: Grey bar at the bottom → Windows are sometimes restored in a wrong position outside of the screen
(Reporter)

Comment 1

2 years ago
I've managed to "get the window back" by running Firefox Aurora with the same profile.
(Reporter)

Comment 2

2 years ago
Created attachment 8736320 [details]
Screencast 2016-03-30 15:29:45.mp4
I guess this happening in Nightly but getting fixed with Aurora indicates this is a regression.

Is this session restore?  bug 1259707?
Or restore from maximised?
Keywords: regression
(Reporter)

Comment 4

2 years ago
Restore from maximised.
See Also: → bug 1276183
Version: Trunk → 48 Branch
status-firefox48: affected → fix-optional
status-firefox49: --- → affected
status-firefox47: --- → unaffected
status-firefox50: --- → affected
Karl, can you take this on, or help find an owner for it, since it's a fairly recent regression? Thanks!
Flags: needinfo?(karlt)
I'm guessing this is related to high dpi coordinate conversion.
I don't know whether or not bug 1287734 would have fixed this, but Jonathan is the expect here.
Flags: needinfo?(karlt) → needinfo?(jfkthame)
"expert", I mean, sorry.
I can't seem to reproduce this with a current Nightly (running on a high-dpi system). I suspect it may have been resolved as part of one of the various dpi-related bugs we've fixed over the past few months.

But it's also possible that I just haven't been testing exactly the right configuration to trigger the problem. Marco, if you still see this, could you please give exact STR, with the details of your display setup, resolution, etc.?
Flags: needinfo?(jfkthame) → needinfo?(mcastelluccio)
Hi Florin,
Can we get QE's help to see if we can still reproduce this in nightly or STR?
Flags: needinfo?(florin.mezei)
(In reply to Gerry Chang [:gchang] from comment #9)
> Hi Florin,
> Can we get QE's help to see if we can still reproduce this in nightly or STR?

Added to our team's todo list. We'll follow up as soon as possible.
Flags: needinfo?(florin.mezei) → needinfo?(andrei.vaida)
I couldn't reproduce the issue on Nightly 48.0a1 (2016-03-30) and 51.0a1 (2016-08-24) on Ubuntu 14.04 x64, Ubuntu 16.04 x86.
Flags: needinfo?(andrei.vaida)
(Reporter)

Comment 12

2 years ago
I couldn't reproduce it reliably, it was quite random.
I haven't seen it in a long time though, so I'll close it as WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mcastelluccio)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.