Make regression-filing template configurable per-performance-framework

RESOLVED FIXED

Status

Tree Management
Perfherder
RESOLVED FIXED
a year ago
6 months ago

People

(Reporter: wlach, Assigned: wlach)

Tracking

(Blocks: 1 bug)

Details

Attachments

(2 attachments)

Currently the regression filing template for bugzilla is specific to Talos. We should make it configurable so it's useable by projects like AreWeFastYet, AutoPhone, and AreWeSlimYet, graphics microbenchmarking, and whatever else starts submitting stuff to Perfherder.
Sounds good.

I've mentioned it in the past, but I think the talos template (and possibly all other/future ones) should really include the main regressed/improved items at the textual report.

Links to alert manager and/or graphs/comparisons etc are great, but just to get the gist of things without following (possibly outdated/modified) links, just put the actual data which resulted in this report.
Blocks: 1261969
Depends on: 1277364
Blocks: 1270524

Comment 2

a year ago
Created attachment 8761372 [details] [review]
[treeherder] wlach:1260805 > mozilla:master
Attachment #8761372 - Flags: review?(jmaher)
Comment on attachment 8761372 [details] [review]
[treeherder] wlach:1260805 > mozilla:master

since r+ auto lands, you get r-, a few nits in the PR
Attachment #8761372 - Flags: review?(jmaher) → review-
Comment on attachment 8761372 [details] [review]
[treeherder] wlach:1260805 > mozilla:master

I addressed your issues. I decided to take out a bit more text from the template to resolve some of them, let me know what you think.

P.S. Autoland only autolands if the autoland keyword is present, which I had accidentally set previously but would not normally. :)
Attachment #8761372 - Flags: review- → review?(jmaher)
Attachment #8761372 - Flags: review?(jmaher) → review+

Comment 5

a year ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/e824b69249d9e417b98310a1c49e4bb49b3bd7b1
Bug 1260805 - Make performance bug template configurable per-project (#1579)

Do this by storing the content of each template in the database (currently
we have just one, for Talos) and adding an API endpoint for fetching it.
For now, we will store the data that should be in each template in a
pre-loaded fixture. Bonus new feature: automatic population of a "CC" list.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED

Comment 6

a year ago
Created attachment 8762158 [details] [review]
[treeherder] wlach:1260805-2 > mozilla:master

Comment 7

a year ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/70141619dfa2d581714183d245128e5d1b3f11e0
Bug 1260805 - Add unit test for bug template API (#1586)
(last push addresses unit tests I forgot to add earlier ^^)

Updated

6 months ago
Assignee: nobody → wlachance
You need to log in before you can comment on or make changes to this bug.