Closed Bug 1260821 Opened 4 years ago Closed 4 years ago

Selected range in console doesn't change when I move mouse pointer over blank space during selection

Categories

(DevTools :: Console, defect, P4)

defect

Tracking

(firefox48 verified)

VERIFIED DUPLICATE of bug 1260839
Tracking Status
firefox48 --- verified

People

(Reporter: arni2033, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

>>>   My Info:   Win7_64, Nightly 48, 32bit, ID 20160326030430
STR:
1. Open data:text/html,<select><option>1<option>2</select><style>a{b:c;d:e;}
2. Open Console
3. Start selecting text, then move mouse pointer to empty area
   below messages in Console and move it to the left and right

AR:  Selected range doesn't change after I hovered mouse over empty area
ER:  Text selection should continue in normal way

This is regression from bug 1237368. Regression range:
> https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=ebaf5066ddd3c718cc2bd421f340809e6ab6f260&tochange=1aed451f1502dc6437d172c6a3e87f36a2a64bcc
See Also: → 1260839
I think this is matching the behavior of text selection in Firefox.  For instance, if I start selecting text in `data:text/html,Lorem ipsum dolor sit amet, consectetur adipiscing elit. Donec dapibus efficitur sem vitae pellentesque. Pellentesque gravida laoreet scelerisque. Curabitur rhoncus purus magna, non facilisis eros tempus non. Ut blandit elit quis ligula aliquet commodo.` then move the mouse to below all of the text and move left/right the selection doesn't change.  Of course, if I keep the mouse down then move back into the paragraphs selection resumes as expected.
Priority: -- → P4
(In reply to Brian Grinstead [:bgrins] from comment #1)
> I think this is matching the behavior of text selection in Firefox.
No. What I described is how text selection works in Firefox. You just tested it in a wrong way.
Text selection DOES start and continue when I move mouse below the text.
Why does everybody need to say that any change is good even if it's obviously bad and wasn't
planned? Especially using clearly wrong arguments. Now I understand that there's no plan at all

Fortunately it was FIXED by bug 1260839.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1260839
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.