Closed Bug 1260949 Opened 4 years ago Closed 4 years ago

Print Preview of SVG images is broken

Categories

(Core :: Print Preview, defect)

41 Branch
All
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: karlcow, Unassigned)

References

Details

(Keywords: regression)

Steps to Reproduce

    Navigate to: http://design-types.net/certificate.html?type=SAIT&ukey=564738ed1c03c
    Print the page (print preview is enough)

Expected Behavior:
The printout should look like the page.

Actual Behavior:
The two graphs at the bottom (svg images) are messed up.

BTW:
Firefox 40.0.2 works just fine. Safari, Chrome, and Opera are fine, too.



Bugs and screenshots are available in the webcompat issue
https://webcompat.com/issues/1947
Hi,

I have tried to reproduce the issue on the latest Firefox release (45.0.1, Build ID 20160315153207) and the latest Nightly (48.0a1, Build ID 20160403030243) and I wasn't able to reproduce it. The printout is not broken when viewed with Print Preview and after it was printed. 
Could you please try to reproduce the issue on the latest Firefox release and provide your results? When doing this please use a new, clean profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E). 

Thanks,
Cipri
Flags: needinfo?(kdubost)
Using Firefox Nightly 48.0a1 (2016-04-03)
built from https://hg.mozilla.org/mozilla-central/rev/55d557f4d73ee58664bdf2fa85aaab555224722e
Clean profile.

uname -a
Darwin ****.local 15.4.0 Darwin Kernel Version 15.4.0: Fri Feb 26 22:08:05 PST 2016; root:xnu-3248.40.184~3/RELEASE_X86_64 x86_64


Print Preview on macosx. It requires to do Print PDF, then Open in Preview.
Still broken.
Flags: needinfo?(kdubost)
Last good revision: 9fa312e065e1e9da9b5cb3514c3b40dcc7f65539
First bad revision: 33f3b919ef1b3cdeeb815362b6611bed030b5728
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9fa312e065e1e9da9b5cb3514c3b40dcc7f65539&tochange=33f3b919ef1b3cdeeb815362b6611bed030b5728

Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=977805
OS: Unspecified → Mac OS X
Hardware: Unspecified → All
That seems like a really odd regression range. Ciprian, can you please verify the range from comment 3? Also, is this still happening in newer versions?
Blocks: 977805
Flags: needinfo?(ciprian.muresan)
Version: unspecified → 41 Branch
User Agent  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:50.0) Gecko/20100101 Firefox/50.0

I have retested the issue on the latest Nightly (50.0a1, Build ID  20160710030217) and it is no longer reproducible. The SVG images are properly rendered while previewing the page as PDF.

I ran mozregression with find-fix to see what has caused the fix and found the following:
First good revision: 0edb406418261a3b078bab4f108a4948a13dd46f
Last bad revision: 6fed93907a39069b9db866890dd49ccc7e09a176
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6fed93907a39069b9db866890dd49ccc7e09a176&tochange=0edb406418261a3b078bab4f108a4948a13dd46f

Looks like the following bug has the changes which introduced the fix:
https://bugzilla.mozilla.org/show_bug.cgi?id=1201874

This issue was probably fixed by Bug 1201874 as they seem to be similar. So I will mark this as Resolved-Worksforme.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(ciprian.muresan)
Resolution: --- → WORKSFORME
No longer blocks: 977805
Depends on: 1201874
You need to log in before you can comment on or make changes to this bug.