Unwanted caching of textarea data

VERIFIED DUPLICATE of bug 46845

Status

()

Core
Layout: Form Controls
--
major
VERIFIED DUPLICATE of bug 46845
16 years ago
16 years ago

People

(Reporter: Melvyn Sopacua, Assigned: rods (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020201
BuildID:    2002020103

While debugging a perl script and dumping an XML document, into a textarea, via
the CGI::textarea method in Perl, I spent quite a few hours debugging the
perl-script, while I was actually being served a cached version of only the
textarea contents - that is -> In the browser window. The __source__ in
view-source does change.

The URL above, is a dump of the contents. In an earlier version, I did not put
out the 'name' attribute for the doc elements, which are childnodes for the
doctree elements.

After adding the name attribute, this did not change at all. It wasn't until I
viewed the source, that I saw the correct dump there.

After changing the URL in the browser, by appending ?bla (thus defeating any
cache) the display of the textarea changed.
Chanching it back, and I still have the correct version, which numerous
refreshes couldn't accomplish.

Please note, that within this process, I have pressed refresh a number of times
and have added debugging messages above and below the textarea, which displayed
and disappeared, according to my perl script. However - not the textarea.

Reproducible: Always
Steps to Reproduce:
1. Create a script which dumps large ammounts of data into a textarea
2. Change something in that data and press refresh



Actual Results:  The contents in the textarea did not change.

Expected Results:  Changed content in the textarea.

Reasons for major classification:
1) Affects cache module
2) View-source != Display
3) Mozilla becomes unusable for debugging webapps.
Use shift-reload if you want a full refresh....  What you are seeing is a design
feature, not a bug.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
Could we then get a 'ctrl-R maps to shift-reload' or some way to achieve that?

I'm not fond of touching my mouse everytime I make an adjustment to a piece of code.

What is the 'feature' in this behavior anyway?
Any way to disable it?

Comment 3

16 years ago
Verified as dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.