Firefox does not load all profile information properly after running in sudo (Ubuntu)

RESOLVED WONTFIX

Status

()

P5
normal
RESOLVED WONTFIX
3 years ago
11 months ago

People

(Reporter: Davidgleich, Unassigned)

Tracking

45 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160304114936

Steps to reproduce:

1. Use your default firefox profile
2. run firefox in the terminal as sudo
3. run firefox again as normal user


Actual results:

firefox starts firstrun again, and using sync is not possible (unexpected error).
The error happens because when you run firefox as sudo it changes some files as root. Therefore they are owned by root and firefox as normal user can not access them anymore.
for undo just do chown -R user:usergroup /home/USER/.mozilla/firefox/PROFILE


Expected results:

firefox should startup normal again
(Reporter)

Updated

3 years ago
Component: Untriaged → Device Permissions
OS: Unspecified → Linux
Hardware: Unspecified → All
Component: Device Permissions → Untriaged
Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit

Updated

2 years ago
Depends on: 1323302

Updated

2 years ago
Priority: -- → P5
Running under sudo is unsupported and Firefox will no longer start in that situation; see bug 1323302.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.