Don't update the device registration every time we open Sync preferences

RESOLVED DUPLICATE of bug 1262312

Status

()

Firefox
Sync
RESOLVED DUPLICATE of bug 1262312
2 years ago
2 years ago

People

(Reporter: kitcambridge, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

The Sync prefs UI uses the `localName` getter (https://dxr.mozilla.org/mozilla-central/rev/d9f50aa0a1aaf90499b85c31e0f329b762e80fdd/services/sync/modules/engines/clients.js#128-134), which calls the setter as a side effect and updates the device registration.
Bug 1262312 has more context, so closing this one.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1262312
You need to log in before you can comment on or make changes to this bug.