[Nightly 48] Send Tab continues to send the same tabs whenever Firefox Sync in the Send Tab recipient syncs

RESOLVED DUPLICATE of bug 1262021

Status

Cloud Services
Firefox Sync: Cross-client
RESOLVED DUPLICATE of bug 1262021
2 years ago
2 years ago

People

(Reporter: Adrian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2700.0 Safari/537.36

Steps to reproduce:

Using Firefox on iOS (3.0(11) as the sender and Firefox on Windows (Nightly 48) as the recipient:

- I sent one via Safari in iOS using the Firefox Send Tab feature to the recipient.
- Opened Firefox on the recipient and triggered the sync by going to the burger menu and selecting the sync pinwheel.
- I then later sent another tab via the aforementioned methods.

This occurs on a clean profile for Nightly 48 (which has now populated my Send Tab iOS service with multiple identical listings) but does not occur in Firefox Developer Edition 47.


Actual results:

Firefox on Windows, the recipient, upon sync received the first tab. Then it continued to receive the first tab. Every time the sync service was polled, which turns out to be quite a bit (adding/modifying bookmarks as well as at a set interval from the looks of things), it continued to add the same tab.

I then sent another tab (accidentally. Send Tab is a daily, frequent habit for me) and now I receive two tabs every time Firefox polls the sync service, whether it be manual or automatic.


Expected results:

Firefox, upon receiving the synced tab(s) on the desktop should have cleared whatever queue the Send Tab function seems to use. It has functioned that way since Firefox for iOS' introduction.
Sorry for the delay, but this should now be fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1262021
You need to log in before you can comment on or make changes to this bug.