Closed Bug 1262351 Opened 4 years ago Closed 4 years ago

crash in mozilla::dom::indexedDB::`anonymous namespace''::ConnectionPool::CloseDatabase

Categories

(Core :: Storage: IndexedDB, defect, critical)

Unspecified
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1256049
Tracking Status
firefox48 --- affected

People

(Reporter: njn, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-ce7ab108-b979-43a6-956e-2241b2160405.
=============================================================

23 crashes in Nightly since this started happening on April 1st (in Nightly 20160401030216).
khuey: any ideas?
Flags: needinfo?(khuey)
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(khuey)
Resolution: --- → DUPLICATE
Duplicate of bug: 1256049
So the ConnectionPool::CloseDatabase() crashes (only happening since April 1st) have the same root cause/fix as the DatabaseConnection::Close() crashes (happening for over a month)?
Flags: needinfo?(khuey)
If you look at where the linked crash is crashing you'll see that it's a release mode assertion that was added for debugging in bug 1256049.
Flags: needinfo?(khuey)
The reports for this signature are partially broken for me. For example, in these two reports:

https://crash-stats.mozilla.com/report/index/33886f9a-572f-4f73-84e0-6450d2160405
https://crash-stats.mozilla.com/report/index/beb547be-5a20-431b-9c8b-b5f6f2160405

when I try look at the top few stack frames I get this error:

> An error occurred while processing your request
> dom/indexeddb/ActorsParent.cpp@9bd900888753: not found in manifest
(In reply to Nicholas Nethercote [:njn] from comment #5)
> The reports for this signature are partially broken for me. For example, in
> these two reports:
> 
> https://crash-stats.mozilla.com/report/index/33886f9a-572f-4f73-84e0-
> 6450d2160405
> https://crash-stats.mozilla.com/report/index/beb547be-5a20-431b-9c8b-
> b5f6f2160405
> 
> when I try look at the top few stack frames I get this error:
> 
> > An error occurred while processing your request
> > dom/indexeddb/ActorsParent.cpp@9bd900888753: not found in manifest

Bug 1241998
You need to log in before you can comment on or make changes to this bug.