Stop using XUL in the eyedropper window

RESOLVED DUPLICATE of bug 1262439

Status

()

Firefox
Developer Tools: Inspector
--
enhancement
RESOLVED DUPLICATE of bug 1262439
2 years ago
2 years ago

People

(Reporter: pbro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [btpp-fix-later])

(Reporter)

Description

2 years ago
In bug 1259121, we're trying to get rid of XUL as much as possible in the toolbox.
The eyedropper is a tool that uses XUL.

This bug is about migrating from XUL to HTML *inside* the eyedropper frame. It is not about removing XUL to open the eyedropper panel. I will file this separately.

The eyedropper loads the following XUL document in an iframe:
\devtools\client\eyedropper\eyedropper.xul

It should be pretty straightforward to convert this to HTML instead, knowing that the most important element in there is <canvas> which also exists in HTML.
(Reporter)

Updated

2 years ago
See Also: → bug 1262439
(Reporter)

Comment 1

2 years ago
Filter on CLIMBING SHOES.
Priority: -- → P2
Whiteboard: [btpp-fix-later]
Whiteboard: [btpp-fix-later] → [btpp-fix-later][devtools-html-2]
Blocks: 1263741
No longer blocks: 1259121

Updated

2 years ago
Flags: qe-verify?
Priority: P2 → --
Whiteboard: [btpp-fix-later][devtools-html-2] → [btpp-fix-later] [devtools-html]
Severity: normal → enhancement

Updated

2 years ago
Blocks: 1263750
No longer blocks: 1263741
(Reporter)

Comment 2

2 years ago
Re-implementing the eyedropper as a highlighter in bug 1262439 means rewriting its UI in HTML anyway, so both things will be done in the same bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1262439

Updated

2 years ago
No longer blocks: 1263750
Flags: qe-verify?
Whiteboard: [btpp-fix-later] [devtools-html] → [btpp-fix-later]
You need to log in before you can comment on or make changes to this bug.