Pasting clipboard contents taken form inside <pre> </pre> into any Windows app adds two excessive CRLF pairs

VERIFIED DUPLICATE of bug 98572

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 98572
16 years ago
13 years ago

People

(Reporter: Yakov Markovitch, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020406

Paste of contents taken from a preformatted HTML text (i.e., from text formatted
with <pre> </pre>) into any Windows application (e.g. Notepad) adds two spurious
CRLF.

Reproducible: Always
Steps to Reproduce:
1. Create an HTML page:
<html>
<head>
  <title>Bug test</title>
            
  <meta http-equiv="content-type" content="text/html; charset=KOI8-R">
   <base href="about:blank">
</head>
<body>
   <br>
    
<pre>Hello,     world!<br></pre>
   
</body>
</html>

2. Load it, then select the word "Hello" with mouse and get it to the clipboard.
3. Start Notepad and paste into it.

Actual Results:  The word "Hello" appears with two empty lines after it, while
should appear alone.
Duplicate of "cut & paste from <pre> always adds <newline> at the end of pasted
text"

*** This bug has been marked as a duplicate of 98572 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.