Closed Bug 1262634 Opened 4 years ago Closed 4 years ago

gtk2 build fails with undefined reference to moz_gtk_get_entry_min_height

Categories

(Core :: Widget: Gtk, defect, major)

48 Branch
Unspecified
Linux
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla48
Tracking Status
firefox48 --- fixed

People

(Reporter: ht990332, Assigned: wgianopoulos)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160404125404

Steps to reproduce:

gtk2 build fails with undefined reference to moz_gtk_get_entry_min_height.
I think this causes it https://github.com/mozilla/gecko-dev/commit/a2db24fb140dc6bccf0303bbd7137f558971adaf ?
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Setting importance to "Major" since this is a build issue and since gtk2 builds may still be needed while gtk3 integration reaches a usable state.
Severity: normal → major
Blocks: 1257811
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Assignee: nobody → wgianopoulos
OS: Unspecified → Linux
Attached patch The fixSplinter Review
This fixes the issue for me.
Attachment #8739257 - Flags: review?(karlt)
Comment on attachment 8739257 [details] [diff] [review]
The fix

Thanks, Bill :)
Attachment #8739257 - Flags: review?(karlt) → review+
Whiteboard: check-in needed
(In reply to Karl Tomlinson (ni?:karlt) from comment #3)
> Comment on attachment 8739257 [details] [diff] [review]
> The fix
> 
> Thanks, Bill :)

Thanks for the quick r+
Status: NEW → ASSIGNED
Keywords: checkin-needed
Whiteboard: check-in needed
https://hg.mozilla.org/mozilla-central/rev/766970bd6779
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
You need to log in before you can comment on or make changes to this bug.