Closed Bug 1263132 Opened 7 years ago Closed 7 years ago

[Ubuntu] "Invite a friend to join you" panel is cut off

Categories

(Hello (Loop) :: Client, defect)

x86
Linux
defect
Not set
normal

Tracking

(firefox45 unaffected, firefox46 wontfix, firefox47 affected, firefox48 affected)

RESOLVED WONTFIX
Tracking Status
firefox45 --- unaffected
firefox46 --- wontfix
firefox47 --- affected
firefox48 --- affected

People

(Reporter: phorea, Assigned: standard8)

Details

(Keywords: regression)

Attachments

(1 file)

Attached image buttons cut off
[Affected versions]:
- 46.0b9 
- 47.0a2 2016-04-08 with Hello 1.2.4
- 48.0a1 2016-04-07 with Hello 1.2.6

[Affected platforms]:
- Ubuntu 14.04 x86

[Steps to reproduce]:
1. Launch Firefox with a clean profile
2. Open a random page (e.g. http://www.imdb.com/)
3. Click the Hello button (make sure there are no conversation in the panel) and select "Browse this page with a friend" button
4. Verify "Invite a friend to join you!" panel (on top)

[Expected result]:
- Panel is resized and all the buttons are correctly displayed

[Actual result]:
- "Email Link" and "Facebook" buttons are cut off when there are no conversation in the main Hello panel

[Regression range]:
- This is a Hello add-on regression, it regressed somewhere between 1.2.0 and 1.2.4

[Additional notes]:
- Firefox 45.0.2 with Hello 1.1.14 doesn't have this issue as there the "Invite a friend to join you" panel is automatically placed at the bottom of the page
Add-on regression, adding the keyword.
Keywords: regression
I can't reproduce this on Ubuntu 15.04 with the standard settings using 46.0b9 (1.2.4).

Bogdan, Petruta, any chance we could get some more testing on different ubuntu versions?
Flags: needinfo?(petruta.rasa)
Flags: needinfo?(bogdan.maris)
I couldn't reproduce either under Ubuntu 15.04 64-bit with 46 beta 10 (1.2.6).

The Ubuntu versions where this is reproducible using latest Nightly 48.0a1 with Hello 1.2.6 are:
- 12.04 32-bit
- 14.04 32-bit
- 14.04 64-bit
Flags: needinfo?(petruta.rasa)
Flags: needinfo?(bogdan.maris)
Marking unaffected for 46 since it is not reproducible in beta 10.
Firefox 46 beta 11 is affected, but only on Ubuntu versions prior to 15.04. Sorry for the confusion.
Mark, I don't think this is a blocker since it is limited to older versions. 
But maybe this can be fixed in the next Hello update. Can you find an owner for the bug?
Flags: needinfo?(standard8)
Assignee: nobody → standard8
WONTFIXing for now because we haven't been able to reproduce, and it seems to have impact limited to a specific platform, and the panel is still functional.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Flags: needinfo?(standard8)
You need to log in before you can comment on or make changes to this bug.