Closed Bug 1263252 Opened 4 years ago Closed 4 years ago

Update SeaMonkey cookie code for mozilla-central Bug 1259169 [nsICookieManager::remove() should be back-compatible]

Categories

(SeaMonkey :: Passwords & Permissions, defect)

SeaMonkey 2.45 Branch
defect
Not set

Tracking

(seamonkey2.44+ fixed, seamonkey2.46+ fixed)

RESOLVED FIXED
seamonkey2.45
Tracking Status
seamonkey2.44 + fixed
seamonkey2.46 + fixed

People

(Reporter: philip.chee, Assigned: frg)

References

Details

Attachments

(1 file, 1 obsolete file)

(From Bug 1259169 comment #0)
> In bug 1245184 we changed nsICookieManager::remove(). But that broke many
> addons. We want to support the old prototype of ::remove() for 1 or 2
> releases to give times to addon developers to update their code.
Depends on: 1251368
As far as I can see only the two attributes switched places. Has been backed out of m-c for now so I didn't test it. Setting review when it's ready to be put in.
Assignee: nobody → frgrahl
Comment on attachment 8739580 [details] [diff] [review]
1263252-cookie-remove-options.patch

Underlying Bug 1259169 is now on m-i and should land today or tomorrow
Attachment #8739580 - Flags: review?(philip.chee)
Comment on attachment 8739580 [details] [diff] [review]
1263252-cookie-remove-options.patch

For consistency you should fix order in the Cookie constructor in cookieViewer.js, and _makeCookieObject: in dataman.js
Status: NEW → ASSIGNED
V2 Change remove calls and reorder constructors to match key fields.
Attachment #8739580 - Attachment is obsolete: true
Attachment #8739580 - Flags: review?(philip.chee)
Attachment #8740508 - Flags: review?(philip.chee)
Comment on attachment 8740508 [details] [diff] [review]
1263252-cookie-remove-options-V2.patch

nice. r=me
Attachment #8740508 - Flags: review?(philip.chee) → review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/4560655b6160b9e2ceaff774b66092bf7a556a7a
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.45
Comment on attachment 8740508 [details] [diff] [review]
1263252-cookie-remove-options-V2.patch

[Approval Request Comment]
Regression caused by (bug #): 1259169 - nsICookieManager::remove() should be back-compatible for 1 or 2 releases
User impact if declined: Cookie Viewer and Data Manager would break. Cookie removal would fail or cause unexpected results.
Testing completed (on m-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): none. Functionality is broken without the patch.
String changes made by this patch: none.
Attachment #8740508 - Flags: approval-comm-aurora?
Bug 1259169 has just been put into m-a too.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 8740508 [details] [diff] [review]
1263252-cookie-remove-options-V2.patch

a=me for comm-aurora.
Attachment #8740508 - Flags: approval-comm-aurora? → approval-comm-aurora+
Keywords: checkin-needed
Whiteboard: [checkin-needed comm-aurora Comment 9]
http://hg.mozilla.org/releases/comm-aurora/rev/dd86a1b531ee
http://hg.mozilla.org/releases/comm-aurora/rev/7d7b42759895
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [checkin-needed comm-aurora Comment 9]
You need to log in before you can comment on or make changes to this bug.