Add a card so it is near the horizontal splitter, results in erratic behavior

VERIFIED DUPLICATE of bug 121583

Status

SeaMonkey
MailNews: Address Book & Contacts
VERIFIED DUPLICATE of bug 121583
16 years ago
13 years ago

People

(Reporter: Ninoschka Baca, Assigned: varada)

Tracking

({hang})

Trunk
mozilla1.0
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ADT2])

(Reporter)

Description

16 years ago
Trunk build 2002-02-14: Win 2k

Overview: In an existing profile, keep adding cards and eventually you will add
a card that will display close to the horizontal splitter. When this happens
then the app freezes.

Steps to reproduce:
1. Open an existing profile
2. Open the address book
3. Add cards and continue adding cards until one meets the horizontal splitter

Actual Results: 
- Windows: it freezes
- Linux: Seth says that it will appear to flash
(Reporter)

Comment 1

16 years ago
Additional Information:
- Windows: Even after an exit/restart, everytime I open the address book then
the application hangs.

Marking nsbeta1 due to the permanent hang, even after an exit/restart.
Keywords: hang, nsbeta1
Summary: Add a card so it appears near the horizontal splitter, freeze → Add a card so it appears near the horizontal splitter, results in a hang

Comment 2

16 years ago
Discussed in 2/28/02 Mail & News bug meeting.  Decision was to plus this bug.
Keywords: nsbeta1 → nsbeta1+
Target Milestone: --- → mozilla1.0
(Reporter)

Updated

16 years ago
Blocks: 128661

Comment 3

16 years ago
Racham or Nbaca:  when this happens, can you "break" in the debugger and try to
get a stack trace of the hang?  That would help a lot.
(Assignee)

Comment 4

16 years ago
If I understand this right - when you say Add a card you mean Clicking on New
CARD and adding multiple entries one by one. 
I tried this with my daily builds and am unable to reproduce this. I tried both
with an existing addressbook as well as with a new one with and without existing
entries in them.
Can you verify if this is a WFM ninoschka?
(Assignee)

Updated

16 years ago
Whiteboard: Not able to reproduce - wfm?
(Assignee)

Comment 5

16 years ago
Taking bugs from bhuvan.
Assignee: racham → varada
(Reporter)

Comment 6

16 years ago
Trunk build 2002-03-26: WinMe, linux, mac 10.1.3
I haven't seen this problem in a while
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

16 years ago
Verified Worksforme.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

16 years ago
*** Bug 135788 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

16 years ago
Reopening since problem is occuring on the latest linux builds.

- trunk build 4/5 and 4/8: Linux RH 7.1: erratic behavior of horizontal divider.
- trunk build 4/5: WinMe, Mac 10.1.3: ok
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 10

16 years ago
Marking nsbeta1 since this problem has returned in the latest linux builds. It
does not hang on linux but the divider flashes.
Workaround: Select another addressbook, resize the window to make more room for
the last card to display then select the original address book and the flashing
stops for that profile.

Since it's specific to linux, changing the summary from "Add a card so it
appears near the horizontal splitter, results in a hang" to "Add a card so it is
near the horizontal splitter, results in erratic behavior"
Keywords: nsbeta1+ → nsbeta1
Summary: Add a card so it appears near the horizontal splitter, results in a hang → Add a card so it is near the horizontal splitter, results in erratic behavior
Whiteboard: Not able to reproduce - wfm?

Comment 11

16 years ago
Happened to me too (WinME) until a few days ago.

Comment 12

16 years ago
Discussed in Mail News bug mtg with Engineering QA and PjM.  Decided to ADT2 and
plus this bug.
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [ADT2]
(Reporter)

Comment 13

16 years ago
*** Bug 134427 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 14

16 years ago
The problem is easily reproduced on my systems in a new profile where the panes
have not been resized.

Branch build 2002-04-23: WinMe, Address Book directory pane displays a freeze
problem  (can't move the window or access the menus) when a new address book is
added and it just touches the horizontal splitter. Workaround: resize the
sidebar down and it is no longer hung. 

Branch build 2002-04-23: Linux RH 7.1, Address Book results pane displays the
erratic (flickering) behavior when a new card touches the horizontal splitter.
Workaround: select another address book, resize the results pane horizontal
splitter, go back to the original address book and it's ok. 

Branch build 2002-04-23: Mac 9.1, Can reproduce the problem in the directory
pane and the results pane. It's worse on the Mac because after resizing the
window it stops flickering but if I resize it back so that the last card touches
the horizontal splitter then it starts flickering again. 
(Assignee)

Comment 15

16 years ago
CCing hewitt and hyatt for their comments. andreww informed me that hewitt might
know of a similar problem.

Comment 16

16 years ago
Sounds like bug 121583
(Assignee)

Comment 17

16 years ago

*** This bug has been marked as a duplicate of 121583 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 18

16 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.