consider implementing ClientHints

RESOLVED DUPLICATE of bug 935216

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 935216
2 years ago
2 years ago

People

(Reporter: bkelly, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
There have been some spec changes to fetch relating to ClientHints headers.  I don't think we implement ClientHints yet.  Its unclear if we want to implement it or not, but I'm filing this so we can track our deviation from the spec here:

See:

  https://github.com/whatwg/fetch/issues/52
  https://github.com/httpwg/http-extensions/issues/141
  https://github.com/whatwg/fetch/commit/404dc3acfddb5e9870fdee333302f80ecff661dd

I'm not sure what component this goes in, so sticking it in DOM for now.

Comment 1

2 years ago
Ben, fwiw, there is already: https://bugzilla.mozilla.org/show_bug.cgi?id=935216 - perhaps worth merging?
(Reporter)

Comment 2

2 years ago
Thanks!
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 935216
You need to log in before you can comment on or make changes to this bug.