Closed Bug 1263478 Opened 6 years ago Closed 3 years ago

libbonjour.so fails to load

Categories

(Instantbird :: Other, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: florian, Unassigned)

Details

(Whiteboard: [1.6-blocking])

Failed to load native module at path 'obj-x86_64-pc-linux-gnu/dist/instantbird/components/libbonjour.so': (80004005) libpurplexpcom.so: cannot open shared object file: No such file or directory

The problem is that components.manifest seems sorted alphabetically, and libbonjour.so appears in it before libpurplexpcom.so.

Ideas for possible fixes:
1. rename libbonjour.so to something that would be sorted after libpurplexpcom.so
2. do some makefile hackery so that the libpurplexpcom.so line is already the first one of the file.
On the behalf of Florian:
Closing bugs related to the Instantbird UI as WONTFIX, as the development of the standalone chat client Instantbird has stopped. Instantbird users are encouraged to migrate to Thunderbird. The user interface of instant messaging in Thunderbird will feel familiar, as the Thunderbird IM support started as a fork of Instantbird.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.