Closed Bug 1263678 Opened 6 years ago Closed 6 years ago

Don't blacklist OGL on Linux if we don't have TextureFromPixmap

Categories

(Core :: Graphics: Layers, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla49
Tracking Status
firefox49 --- fixed
relnote-firefox --- -

People

(Reporter: BenWa, Assigned: lsalzman)

References

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

This blacklist doesn't make any sense since we don't use the extension.
We don't actually use TFP unless it is pref'd on at current, and when it is pref'd on, it is broken anyway until we have time to reevaluate it and GL context initialization for it.

Since OpenGL layers still offers a performance advantage over basic layers even without TFP, it makes no sense to blacklist because of a lack of TFP at present.
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Attachment #8746153 - Flags: review?(karlt)
See Also: → 1167557
Comment on attachment 8746153 [details] [diff] [review]
don't block OpenGL layers when lacking EXT_texture_from_pixmap

Any reason to keep the code?
Are you planning to resurrect a variant at some stage?
Attachment #8746153 - Flags: review?(karlt) → review+
https://hg.mozilla.org/mozilla-central/rev/963cf67776be
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
Release Note Request (optional, but appreciated)
[Why is this notable]:
[Suggested wording]: Linux installations not supporting EXT_texture_from_pixmap OpenGL extension are not blocked from OpenGL acceleration anymore.
[Links (documentation, blog post, etc)]:
relnote-firefox: --- → ?
Relnote -, pretty technical description that we are not sure would be helpful to end users.
Duplicate of this bug: 1228840
Duplicate of this bug: 1184502
You need to log in before you can comment on or make changes to this bug.