Closed Bug 1263683 Opened 4 years ago Closed 4 years ago

GCLI close-button icon is missing

Categories

(DevTools Graveyard :: Graphic Commandline and Toolbar, defect)

Unspecified
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1260751

People

(Reporter: dholbert, Unassigned)

References

Details

Attachments

(2 files)

STR:
 1. Open Developer Toolbar (Shift F2)

EXPECTED RESULTS: Close button at far right.
ACTUAL RESULTS: Blank empty space at far right.

If I click the blank space, the toolbar closes -- so the button is there. It's just missing an icon.
Component: Developer Tools → Developer Tools: Graphic Commandline and Toolbar
I'm using 64-bit Nightly 48.0a1 (2016-04-08) on Ubuntu Linux 16.04.
Regression range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=603181ac9e84f9a4a8dd6471e880860088f1d813&tochange=2a8ca5caae8e3a300701b0a85e5051ead55e0648

Looks like a regression from
> 2ee670054a59 Philip Chee — Bug 1257348 Fix for GCLI close button disappears when hovered over r=bgrins

Presumably that patch fixed whatever the hover issue was on some platforms, but it seems to have broken the icon on my Linux machine. (per this bug)

This is particularly concerning given that the patch was uplifted to Aurora -- so now we'll be shipping this regression directly to beta in a few weeks.  (I confirmed that I can reproduce this bug in the latest Aurora release, too.)

Philip or Brian, could you take a look at this and see if we can get this missing button fixed before we ship it as a beta regression?
Blocks: 1257348
Flags: needinfo?(philip.chee)
Keywords: regression
Summary: Developer Toolbar close-button icon is missing → GCLI close-button icon is missing
[Tracking Requested - why for this release]: Very recent regression in nightly & now aurora (via an uplift of the regressing patch)
(This might be Linux-specific. I can't reproduce on Windows, at least -- only on Linux.)
OS: Unspecified → Linux
I think this is a dupe of Bug 1260751, I'll copy the flags over to that bug
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(philip.chee)
Resolution: --- → DUPLICATE
Duplicate of bug: 1260751
Yeah, looks like it. Thanks! I'll clear out the flags here so they don't end up with stale values if the situation changes on some version or another.
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.