remove the nsIBadCertListener2 implementation in exceptionDialog.js to avoid spamming of "Error: 2147500034 exceptionDialog.js"

RESOLVED FIXED in Firefox 59

Status

()

defect
P1
normal
RESOLVED FIXED
3 years ago
5 months ago

People

(Reporter: keeler, Assigned: keeler)

Tracking

Trunk
mozilla59
Points:
---

Firefox Tracking Flags

(firefox59 fixed)

Details

(Whiteboard: [psm-assigned])

Attachments

(2 attachments)

The nsIBadCertListener2 implementation in exceptionDialog.js is unnecessary and causes some debug when necko tries to QI it to nsILoadContext. We can just replace it with an onerror handler on the XHR.
Posted image error.png
I'm assuming this is the same issue. I've ran into the following error several times via the browser console:

Error: 2147500034 exceptionDialog.js:32:11

badCertListener.prototype.QueryInterfacechrome://pippki/content/exceptionDialog.js:32:11
badCertListener.prototype.getInterfacechrome://pippki/content/exceptionDialog.js:23:12
checkCertchrome://pippki/content/exceptionDialog.js:110:43
anonymouschrome://global/content/bindings/dialog.xml%20line%20380%20%3E%20Function:1:1
_fireButtonEventchrome://global/content/bindings/dialog.xml:381:28
_doButtonCommandchrome://global/content/bindings/dialog.xml:349:28
_handleButtonCommandchrome://global/content/bindings/dialog.xml:337:18
BrowserOnClick.onCertErrorchrome://browser/content/browser.js:2890:9
BrowserOnClick.receiveMessagechrome://browser/content/browser.js:2794:9

STR:

* open https://untrusted-root.badssl.com/
* open the browser console
* click on Advanced -> Add Exception
* Once you receive the exceptionDialog, click on "Get Certificate" and you'll several of the above errors

Build Used:
* fx51.0a1, buildId: 20160810030202, changeset: 6cf0089510fa
Duplicate of this bug: 1311570
Priority: -- → P3
Summary: remove the nsIBadCertListener2 implementation in exceptionDialog.js → remove the nsIBadCertListener2 implementation in exceptionDialog.js to avoid spamming of "Error: 2147500034 exceptionDialog.js"
Assignee: nobody → dkeeler
Priority: P3 → P1
Whiteboard: [psm-cleanup] → [psm-assigned]
Comment on attachment 8942008 [details]
bug 1263765 - remove nsIBadCertListener2 implementation from the add certificate exception dialog

https://reviewboard.mozilla.org/r/212210/#review218314

\ /
 |
/o\
Attachment #8942008 - Flags: review?(jjones) → review+
Pushed by dkeeler@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d5dd45fa551c
remove nsIBadCertListener2 implementation from the add certificate exception dialog r=jcj
https://hg.mozilla.org/mozilla-central/rev/d5dd45fa551c
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
Duplicate of this bug: 1029456
You need to log in before you can comment on or make changes to this bug.