Closed Bug 1263788 Opened 4 years ago Closed 4 years ago

Forward slash after backslash in address bar causes "Visit site" suggestion to expose JSON

Categories

(Firefox :: Untriaged, defect)

45 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1233672
Tracking Status
firefox45 --- affected
firefox46 --- affected
firefox47 --- unaffected
firefox48 --- unaffected
firefox-esr38 --- unaffected
firefox-esr45 --- affected

People

(Reporter: bennett.ramirez, Unassigned)

Details

Attachments

(1 file)

Attached image actual.png
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160407164938

Steps to reproduce:

I started an empty profile in Firefox 45.0.2. I immediately went to the address bar, cleared it, and typed in "google.com/\" (without the quotation marks).


Actual results:

The only suggestion below the address bar was:
Visit {"url": "http://google.com/\", "input":"http://google.com/\\"}

This means that the address bar's text may not have been properly escaped beforehand and thus caused the suggestion to display in JavaScript object form rather than as a readable URL.


Expected results:

The suggestion that should have come up was:
Visit http://google.com/\

However, in order for this intended result to appear, currently I have to enter two forward slashes.
Fixed by Bug 1233672 in 47.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1233672
You need to log in before you can comment on or make changes to this bug.