.part file doesn't appear to change to the right extension when downloading a Quicken .qfx file

RESOLVED INVALID

Status

()

Toolkit
Downloads API
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: streetwolf, Unassigned)

Tracking

48 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160412073343

Steps to reproduce:

1. Install A Windows version of Quicken.  I use the latest QW2016.  Don't know if older versions will exhibit the same problem or even other Operating Systems.

2. Go to your financial institutions website and download transactions from an account.  They must use Quicken OFX data format which are .qfx files.


Actual results:

I am presented with the download window and when I select open Quicken starts up thinking I am a new user.  If Quicken is already running I get some error message.

Looking at my Windows Temp folder I see the .qfx file has an extension of .part.  My guess is that the .part isn't being converted to .qfx.  This results in Quicken thinking I am a new user or I get an error when it tries to open a .part file.  Btw.. .qfx files are really just XML files.


Expected results:

The .qfx file should be opened by Quicken and my transactions should appear ready to be entered into my Quicken register.

All was working fine until a week or two ago.  I can download the .qfx file and save it in my download folder.  Clicking on the file opens up Quicken with no problems.  This is my work around.
(Reporter)

Updated

2 years ago
Component: Untriaged → Download Manager
Product: Firefox → Toolkit
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

2 years ago
In mimeTypes.rdf the following entry exists.  Could my problem be the fact that an xml file is being passed to Quicken when it expects a qfx file?

<RDF:Description RDF:about="urn:mimetype:externalApplication:text/xml"
                   NC:path="C:\Program Files (x86)\Quicken\qw.exe"
                   NC:prettyName="qw.exe" />
(Reporter)

Comment 2

2 years ago
I ran Fx45.0.2 portable version and received the same results.  How exactly does Fx know what extension to name the .part extension to?
(Reporter)

Comment 3

2 years ago
I ran Process Monitor against both Fx and Quicken.  It appears that the .part file is being renamed to:

some_temp_name.qfx.xml. 

Passing an XML file to Quicken is probably the reason Quicken can't open it.  The file has to end in qfx not xml.  As I said the qfx file is really an xml file.  How do I get Fx to use the qfx extension?
(Reporter)

Comment 4

2 years ago
Created attachment 8741134 [details]
quicken.png

The open window has the correct extension even though it passes it to Quicken as .qfx.xml.
(Reporter)

Comment 5

2 years ago
Created attachment 8741190 [details]
quicken.png

Saved a qfx file to my OneDrive folder and then used Fx's download manager to open it.  Everything worked fine.  Also, there was no .part file in my temp folder.  The file in my temp folder ended in .qfx.  See the attachment.
(Reporter)

Comment 6

2 years ago
If you need any more info please let me know.
(Reporter)

Comment 7

2 years ago
Some more info.

The part file that gets created in my Windows temp folder is something like erueuu.xml.part.  Shouldn't the file be erueuu.qfx.part?  I'm assuming that when you rename the extension you just drop the .part and the file becomes an xml file which Quicken doesn't know how to process.

The strange part is that when I save the file instead of opening it it is the same file (...xml.part) but it gets renamed to a .qfx file.  One of my screenshots above shows the name of the qfx file which is much longer than the temp file.
(Reporter)

Comment 8

2 years ago
Anyone?
(Reporter)

Comment 9

2 years ago
My issue appears not to be related to Fx but to my bank or Quicken.  Please close.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.