TryChooser cannot load the number of jobs in queues

RESOLVED DUPLICATE of bug 1260609

Status

RESOLVED DUPLICATE of bug 1260609
3 years ago
a year ago

People

(Reporter: xidorn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
TryChooser shows ??? or NaN for Build Queue and Test Queue columns.

From the web console, it shows:
> Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at http://builddata.pub.build.mozilla.org/reports/pending/pending_test_all.txt. (Reason: CORS header 'Access-Control-Allow-Origin' missing).

and the url mentioned is actually 404.

Updated

2 years ago
Duplicate of this bug: 1267826
Do we have a plan to solve this bug yet?
Flags: needinfo?(coop)
Nick: was it your scripts that was feeding this before? Should we try to grab them off of the old cruncher VM, or setup something new? 

We could probably look up this data directly from buildapi: http://buildapi.pvt.build.mozilla.org/buildapi/pending?format=json (or public equiv)
Flags: needinfo?(coop) → needinfo?(nthomas)
Yes, it piggybacked off the graphs I had for pending/running jobs. I filed bug 1260609 so show the ? rather than defaulting to 0. I was hoping we could use the same mechanism to categorize jobs as slavehealth does, which is client-side IIRC, to avoid divergence. Is that plausible ?
Flags: needinfo?(nthomas)
(In reply to Nick Thomas [:nthomas] from comment #4)
> Yes, it piggybacked off the graphs I had for pending/running jobs. I filed
> bug 1260609 so show the ? rather than defaulting to 0. I was hoping we could
> use the same mechanism to categorize jobs as slavehealth does, which is
> client-side IIRC, to avoid divergence. Is that plausible ?

Should be. The code is here:

https://hg.mozilla.org/build/slave_health/file/63b58384fb45/js/slave_health.js#l68
If anyone wants to work on this, the code is at http://hg.mozilla.org/build/tools/file/default/trychooser/ and you can load/develop it directly in your own web browser.
Oh, that's why I was sort of confused, there's two of these.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1260609
(Assignee)

Updated

a year ago
Component: Tools → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.