Intermittent browser_webconsole_bug_651501_document_body_autocomplete.js,browser_switch_to_customize_mode.js | application crashed [@ js::gc::MaybeForwarded<JSObject *>(JSObject *)]

RESOLVED DUPLICATE of bug 1302914

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1302914
3 years ago
2 years ago

People

(Reporter: cbook, Unassigned)

Tracking

({crash, intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=8612177&repo=fx-team


PROCESS-CRASH | devtools/client/webconsole/test/browser_webconsole_bug_651501_document_body_autocomplete.js | application crashed [@ js::gc::MaybeForwarded<JSObject *>(JSObject *)]

 16:58:03     INFO -  Crash dump filename: c:\users\cltbld~1.t-w\appdata\local\temp\tmpeqlqbd.mozrunner\minidumps\87543c18-824e-4d39-a6fa-446a222796c9.dmp

 16:58:03     INFO -  Operating system: Windows NT

 16:58:03     INFO -                    6.2.9200

 16:58:03     INFO -  CPU: amd64

 16:58:03     INFO -       family 6 model 30 stepping 5

 16:58:03     INFO -       8 CPUs

 16:58:03     INFO -  Crash reason:  EXCEPTION_ACCESS_VIOLATION_READ

 16:58:03     INFO -  Crash address: 0xffffffffffffffff

 16:58:03     INFO -  Process uptime: 146 seconds

 16:58:03     INFO -  Thread 24 (crashed)

 16:58:03     INFO -   0  xul.dll!js::gc::MaybeForwarded<JSObject *>(JSObject *) [jsgc.h:c9369050bd73 : 1163 + 0x6]

 16:58:03     INFO -      rax = 0x0000036580a2baf0   rdx = 0xdb8b4c10cc5c8b48

 16:58:03     INFO -      rcx = 0x000000a3388d53d8   rbx = 0x000000a313e431b0

 16:58:03     INFO -      rsi = 0x000007fb2983da80   rdi = 0x000000a313e7f048

 16:58:03     INFO -      rbp = 0x000000a322cffe20   rsp = 0x000000a322cffcb8

 16:58:03     INFO -       r8 = 0x00000000bad0bad1    r9 = 0x000007fb2983da80

 16:58:03     INFO -      r10 = 0x000007fb2983da80   r11 = 0x000007fb2983da80

 16:58:03     INFO -      r12 = 0x0000000000021e3c   r13 = 0x00000000000771c5

 16:58:03     INFO -      r14 = 0x000000a313e7f048   r15 = 0x0000000000021dbc

 16:58:03     INFO -      rip = 0x000007fb2752c171

 16:58:03     INFO -      Found by: given as instruction pointer in context

 16:58:03     INFO -   1  xul.dll!JSScript::maybeForwardedScriptSource() [jsscript.cpp:c9369050bd73 : 1332 + 0x9]

 16:58:03     INFO -      rbp = 0x000000a322cffe20   rsp = 0x000000a322cffcc0

 16:58:03     INFO -      rip = 0x000007fb276d4a41

 16:58:03     INFO -      Found by: stack scanning

 16:58:03     INFO -   2  xul.dll!mozilla::ThreadStackHelper::AppendJSEntry(StackEntry const volatile *,__int64 &,char const *) [ThreadStackHelper.cpp:c9369050bd73 : 434 + 0x9]

 16:58:03     INFO -      rbp = 0x000000a322cffe20   rsp = 0x000000a322cffcf0

 16:58:03     INFO -      rip = 0x000007fb276d444d

 16:58:03     INFO -      Found by: call frame info

 16:58:03     INFO -   3  xul.dll!mozilla::ThreadStackHelper::FillStackBuffer() [ThreadStackHelper.cpp:c9369050bd73 : 518 + 0x13]

 16:58:03     INFO -      rbp = 0x000000a322cffe20   rsp = 0x000000a322cffde0

 16:58:03     INFO -      rip = 0x000007fb276d4699

 16:58:03     INFO -      Found by: call frame info

 16:58:03     INFO -   4  xul.dll!mozilla::ThreadStackHelper::GetStack(mozilla::Telemetry::HangStack &) [ThreadStackHelper.cpp:c9369050bd73 : 250 + 0x8]

 16:58:03     INFO -      rbp = 0x000000a322cffe20   rsp = 0x000000a322cffe20

 16:58:03     INFO -      rip = 0x000007fb276d439b

 16:58:03     INFO -      Found by: call frame info

 16:58:03     INFO -   5  xul.dll!mozilla::BackgroundHangManager::RunMonitorThread() [BackgroundHangMonitor.cpp:c9369050bd73 : 318 + 0x10]

 16:58:03     INFO -      rbp = 0x000000a322cffe20   rsp = 0x000000a322cffe50

 16:58:03     INFO -      rip = 0x000007fb276d3ffb

 16:58:03     INFO -      Found by: call frame info

 16:58:03     INFO -   6  nss3.dll!PR_NativeRunThread [pruthr.c:c9369050bd73 : 397 + 0x7]

 16:58:03     INFO -      rbp = 0x000000a322cffe20   rsp = 0x000000a322cffea0

 16:58:03     INFO -      rip = 0x000007fb360b344a

 16:58:03     INFO -      Found by: call frame info

 16:58:03     INFO -   7  nss3.dll!pr_root [w95thred.c:c9369050bd73 : 95 + 0x6]

 16:58:03     INFO -      rbp = 0x000000a322cffe20   rsp = 0x000000a322cffed0

 16:58:03     INFO -      rip = 0x000007fb360b2d52

 16:58:03     INFO -      Found by: call frame info

 16:58:03     INFO -   8  ucrtbase.dll + 0x6be1d

 16:58:04     INFO -      rbp = 0x000000a322cffe20   rsp = 0x000000a322cfff00

 16:58:04     INFO -      rip = 0x000007fb348cbe1d

 16:58:04     INFO -      Found by: call frame info

 16:58:04     INFO -   9  kernel32.dll!BaseThreadInitThunk + 0x1a

 16:58:04     INFO -      rsp = 0x000000a322cfff30   rip = 0x000007fb438f167e

 16:58:04     INFO -      Found by: stack scanning

 16:58:04     INFO -  10  ntdll.dll!RtlUserThreadStart + 0x21

 16:58:04     INFO -      rsp = 0x000000a322cfff60   rip = 0x000007fb4422c3f1

 16:58:04     INFO -      Found by: stack scanning

 16:58:04     INFO -  11  KERNELBASE.dll!GetLegacyComposition + 0x1180

 16:58:04     INFO -      rsp = 0x000000a322cfff90   rip = 0x000007fb415209d0

 16:58:04     INFO -      Found by: stack scanning

16:58:04 INFO - Thread 0
Looks like a dupe of bug 1245686 to me.
See Also: → bug 1245686

Comment 2

3 years ago
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
Component: JavaScript Engine → JavaScript: GC
Summary: Intermittent browser_webconsole_bug_651501_document_body_autocomplete.js | application crashed [@ js::gc::MaybeForwarded<JSObject *>(JSObject *)] → Intermittent browser_webconsole_bug_651501_document_body_autocomplete.js,browser_switch_to_customize_mode.js | application crashed [@ js::gc::MaybeForwarded<JSObject *>(JSObject *)]
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1302914
You need to log in before you can comment on or make changes to this bug.