Unlisted, signed Firefox addon shows "could not be verified for use in Firefox" warning in Add-ons Manager

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: olaf--mail.mozilla, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8741137 [details]
Signed, unlisted sample from "Getting Started (jpm)"

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160304114926

Steps to reproduce:

I installed my addon on my Linux computer at `/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/`.

This can also be reproduced with the addon sample described at [Getting Started (jpm)](https://developer.mozilla.org/en-US/Add-ons/SDK/Tutorials/Getting_Started_%28jpm%29)


Actual results:

Even though my addon works properly, there is this warning "could not be verified for use in Firefox" in the Add-ons Manager. Another *listed* addon, installed the same way, doesn't show this warning.

When I install the very same addon via the browser's URL bar as `/usr/share/mozilla/extensions/{ec8030f7-c20a-464f-9b0e-13a3a9e97384}/myaddon.xpi`, it installs successfully and the warning disappears.


Expected results:

The warning shouldn't show up in the first place, because otherwise the signing requirement for unlisted addons doesn't make any sense.

Updated

3 years ago
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
You've sideloaded the add-on and before Firefox 46 there were additional requirements (dropped in bug 1245956)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.