Closed Bug 1264608 Opened 8 years ago Closed 2 years ago

PDF rendered incorrectly; white lines between image chunks

Categories

(Firefox :: PDF Viewer, defect, P3)

47 Branch
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: cb, Unassigned)

References

Details

(Whiteboard: [pdfjs-image-quality])

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160410004056

Steps to reproduce:

Open the attached PDF in Firefox

The PDF file is a rasterised 150 DPI proof. The image in the center should render as a solid image, which is how Chrome and Adobe Acrobat render it. Firefox renders it with white borders around the image chunks.


Actual results:

Firefox renders the PDF with white lines between the rasterised image chunks, which causes the image to appear overlayed with a grid.


Expected results:

Firefox should render the PDF as Acrobat and Chrome do.
Component: Untriaged → PDF Viewer
Dupe of bug 839459 probably.
(In reply to Loic from comment #1)
> Dupe of bug 839459 probably.

Agreed, that looks like the same problem.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Bug 839459 closed because sample pdf is gone
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

The issue still persists. Has anyone ever found the cause or at least a workaround for the PDF Export?

I found a regression range for this issue.
last good: 2012-10-17 (dac5700acf8b)
first bad: 2012-10-18 (cb573b9307e5)
Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dac5700acf8b&tochange=cb573b9307e5
Potential regressor: Bug 801280

The way I managed to reproduce the issue was by printing on Firefox by using "Print to pdf" option a page from pinterest.com and then opened the saved pdf with Firefox.

Severity: normal → S3
Priority: -- → P3

The regression range doesn't help. As the last good build doesn't use pdf.js as pdf viewer.

Severity: S3 → S2
Whiteboard: [pdfjs-image-quality]
Commit merged into master by GitHub
Authored by calixteman (calixteman)

Some of the bugs that were duplicated to this are fixed, except bug 1479849, bug 1680496, and bug 1757351 which still show white lines.

We can close this as fixed, and we'll track the white lines with rectangles in bug 1269455.

Status: REOPENED → RESOLVED
Closed: 8 years ago2 years ago
Resolution: --- → FIXED
See Also: → 1269455
You need to log in before you can comment on or make changes to this bug.