Closed Bug 126463 Opened 18 years ago Closed 18 years ago

Occurances of uninitialized variables being used before being set (in extensions/transformiix).

Categories

(Core :: XSLT, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla1.2alpha

People

(Reporter: mozilla-bugs, Assigned: peterv)

References

Details

(Whiteboard: [fixinhand])

Attachments

(1 file, 1 obsolete file)

This bug is just for the warnings in various source files in
extensions/transformiix/source. Currently
(http://tinderbox.mozilla.org/SeaMonkey/warn1014136200.29882.html - Tue, 19 Feb
2002 11:30 EST) TBox shows the following warnings:

extensions/transformiix/source/xml/parser/nsSyncLoader.cpp:235
 `class txLoadListenerProxy * proxy' might be used uninitialized in this function

extensions/transformiix/source/xpath/ExprParser.cpp:75
 `UNICODE_CHAR endLiteral' might be used uninitialized in this function

extensions/transformiix/source/xpath/XPathProcessor.cpp:49
 `class nsISupports * foundInterface' might be used uninitialized in this function

extensions/transformiix/source/xpath/nsNodeSet.cpp:47
 `class nsISupports * foundInterface' might be used uninitialized in this function

extensions/transformiix/source/xslt/XSLTProcessor.cpp:169
 `class nsISupports * foundInterface' might be used uninitialized in this function

extensions/transformiix/source/xslt/functions/txFormatNumberFunctionCall.cpp:122
 `UNICODE_CHAR c' might be used uninitialized in this function
Bug 59652 is the meta-bug tracking the fight against these (potentially very
nasty) warnings.

P.S. Trying to make sure that 1.0 has as little warnings as possible.

Blocks: 59652
Keywords: mozilla1.0
class nsISupports * foundInterface should be filed on the macro
NS_IMPL_QUERY_HEAD. I'll attach a patch for the others.
Assignee: kvisco → peterv
OS: Linux → All
Priority: -- → P3
Hardware: PC → All
Target Milestone: --- → mozilla1.0
Attached patch Fix some warnings (obsolete) — Splinter Review
+    nsCOMPtr<nsIDOMEventReceiver> target = do_QueryInterface(DOMDocument, &rv);
+    NS_ENSURE_SUCCESS(rv, rv);

don't check the error-value from do_QI, NS_ENSURE_TRUE(target) instead (at 
least that's what i've been told is the "right" way)

with that, r=sicking
Comment on attachment 70432 [details] [diff] [review]
Fix some warnings

(no need for new patch)
Attachment #70432 - Flags: review+
once but 92929 is fixed this shouldn't be a problem ;-)
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
Target Milestone: mozilla1.0 → mozilla1.2
Looks like proxy is the only unitialized var left and it looks like it could
well be real, so it would be nice to have the fix for this...

I have a fix for 'class nsISupports * foundInterface' stuff.
Whiteboard: [fixinhand]
Attached patch Fix v2Splinter Review
Attachment #70432 - Attachment is obsolete: true
Comment on attachment 74522 [details] [diff] [review]
Fix v2

Moving the r=sicking
Attachment #74522 - Flags: review+
Comment on attachment 74522 [details] [diff] [review]
Fix v2

sr=jst
Attachment #74522 - Flags: superreview+
Comment on attachment 74522 [details] [diff] [review]
Fix v2

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #74522 - Flags: approval+
Checked in.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Verifying, currently
(http://tinderbox.mozilla.org/SeaMonkey/warn1016552220.1515.html - Tue, 19 Mar
2002 10:37 EST) I do not see any such warnings in extensions/transformiix. Thanks!
Status: RESOLVED → VERIFIED
This have regressed - bug 113611 checkin have added 4 new "might be used
uninitialized" warnings in extensions/transformiix:

+extensions/transformiix/source/xslt/Numbering.cpp:80
+ `enum txNodeTypeTest::NodeType nodetype' might be used uninitialized in this
function
+
+extensions/transformiix/source/xslt/ProcessorState.cpp:194
+ `double priority' might be used uninitialized in this function
+
+extensions/transformiix/source/xslt/ProcessorState.cpp:513
+ `MBool hasAttr' might be used uninitialized in this function
+
+extensions/transformiix/source/xslt/ProcessorState.cpp:555
+ `MBool hasAttr' might be used uninitialized in this function
This is not a regression, but new occurences.
The code is safe though, I will fix the warnings later on, in a different bug.
Axel, two of the warnings are still there:

extensions/transformiix/source/xslt/Numbering.cpp:80
 `enum txNodeTypeTest::NodeType nodetype' might be used uninitialized in this
function

extensions/transformiix/source/xslt/ProcessorState.cpp:234
 `double priority' might be used uninitialized in this function

The first one should be part of bug 94036, the second one is wrong anyway.
Anyway, this bug is not about those. The ones that this bug was about have been
fixed.
You need to log in before you can comment on or make changes to this bug.