Closed Bug 1265104 Opened 4 years ago Closed 9 months ago

There Is No Dragged Text Following in Moving Cursor When Dragging a Link inside the Web Component(Shadow DOM), or inside display: contents;

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: bevis, Assigned: smaug)

References

(Blocks 1 open bug)

Details

(Whiteboard: btpp-backlog)

Attachments

(3 files)

This is a follow-up of the no-dragged-text problem found in bug 1264380 comment 11.
See Also: → 1264380
William is still working on our Shadow DOM implementation so since were not yet ready to ship that (and AFAIK the spec isn't finalized yet either), I'm going to mark this as backlog.
Whiteboard: btpp-backlog
Priority: -- → P3

Still valid for the ShadowDOM v1 API.

Blocks: shadowdom
Attached file testcase

try dragging the link.
Interestingly selection the text and then dragging does work.

Component: DOM → Layout

The issue seems to be in PresShell::CreateRangePaintInfo where we get null ancestorFrame.

Ah, there is a comment
// XXX deal with ancestorFrame being null due to display:contents
Shadow DOM issue is similar.

This test doesn't use Shadow DOM, only display: contents;

Blocks: 907396
Summary: There Is No Dragged Text Following in Moving Cursor When Dragging a Link inside the Web Component(Shadow DOM). → There Is No Dragged Text Following in Moving Cursor When Dragging a Link inside the Web Component(Shadow DOM), or inside display: contents;
Assignee: nobody → bugs

I ended up taking rather simple approach. Common ancestor can already cross shadow boundaries and what not, so flattened parent wouldn't be needed, just some reasonable parent.

And this code is used in dnd only, so no automated tests :/

Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e5e2e0d4eb05
paint dnd'ed content also when it is under non-displayed content (display: contents or ShadowRoot), r=emilio
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
QA Whiteboard: [qa-67b-p2]
Duplicate of this bug: 1550728
You need to log in before you can comment on or make changes to this bug.