If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Pinned tabs are lost after closing browser

RESOLVED INVALID

Status

()

Firefox
Session Restore
RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: yonezpt, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36

Steps to reproduce:

Opened Nightly through shortcut with profile selector commands "-p <profilename> -no-remote" and pinned pages: tested with a single pinned page or multiple pages. Close browser, open again.


Actual results:

All the pinned pages are gone, during the tests not one tab remained pinned after opening the browser again.

This has been happening for quite some time and few past versions, but tested for confirmation on current Nightly 48.0a1 (2016-04-15)


Expected results:

Any pinned tab should remain pinned when the browser is opened again.

Updated

2 years ago
Component: Untriaged → Session Restore
(Reporter)

Comment 1

a year ago
Was finally able to find the cause of this. When the History settings in the Privacy options page is set to "Never remember history" no pinned tabs will be saved. Activating history memorization allows pinned tabs to be remembered. I assume this is the intended behavior and for that reason I will close this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.